rodion12345678958
27.06.2020 01:45

Напишите программу через цикл repeat. Дано натуральное число n найти количество цифр в десятичной записи числа.​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
maksym200178
28.01.2023 04:58

#include <iostream>

using namespace std;

int main () {

   int n;

   cin >> n;

   if (n==0) {

       cout << "0  0" << endl << 1 << endl << 1 << endl;

       return 0;

   }

   int mx=0; int mn=10; int mxi=10; int mnk=0; int ind=0;

   while (n>0) {

       int c=n%10;

       n/=10;

       if (c>=mx) {

           mx=c;

           mxi=ind;

       }

       if (c<mn) {

           mn=c;

           mnk=1;

       } else if (c==mn) {

           ++mnk;

           ++ind;

       }

   }

   cout << mx << " " << mn << endl << (ind - mxi) << endl << mnk << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
Shaurma021
22.09.2021 14:05
На Java:

class SearchPalin{
 public static void main(String args[]){
  String palinString = new java.util.Scanner(System.in).nextLine();
  System.out.print("\nПалиндром(-ы):\n  ");
  for(int wordStart = 0, wordEnd = 0; wordEnd<palinString.length(); wordEnd++)
   if(wordEnd+1==palinString.length() || palinString.charAt(wordEnd+1)==' '){
 String wordBeginning = "", wordEnding = "";
 for(int wordBe = wordStart;wordBe<wordEnd+1;wordBe++)wordBeginning+=palinString.charAt(wordBe);
 for(int wordEn = wordEnd;wordStart-1<wordEn;wordEn--)wordEnding+=palinString.charAt(wordEn);
 if(wordBeginning.equals(wordEnding)){
  for(int palinWord = wordStart;palinWord<=wordEnd;palinWord++)System.out.print(palinString.charAt(palinWord));
  System.out.print("\n  ");
 } wordStart = wordEnd+2;
   }
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота