Карина9653
01.05.2020 05:17

Паскаль
Дан массив целых чисел, размер массива не превышает 1000 чисел. Напишите программу, которая вводит в начале размер массива, затем сами элементы. Далее программа подсчитывает количество элементов, у которых все цифры одинаковые.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Light111111
11.10.2020 06:01

package com.company;

import java.util.Arrays;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner sc = new Scanner(System.in);

       System.out.print("Введите размер массива: ");

       int size = sc.nextInt();

       int[] myArray = new int[size];

       System.out.print("Заполните элементы массива: ");

       for(int i=0; i<size; i++) {

           myArray[i] = sc.nextInt();

       }

       System.out.print("Одинаковые элементы: ");

       for(int i=0; i<myArray.length; i++) {

           for (int j=i+1; j<myArray.length; j++) {

               if(myArray[i] == myArray[j]) {

                   System.out.println(j);

               }

           }

       }

   }

}

Объяснение:

Я использую язык программирования java, думаю переписать на нужный вам вы сможете.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота