Luka2015
10.10.2021 01:38

Работа на языке программирования "Кумир"

1) Написать команды в «роботе», которые выведут ваше имя. Ввести имя Саша 2) Составить программу на языке «Кумир». Решите пример y = 10 + x + z. Вводим ЛЮБОЕ число x. z – количество букв вашего имени. (число z = 4)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ersultanplay
17.12.2020 17:32
Const
    auto = false;

var
    soldier: array[1..5000]of integer;
    n, i, j, k, max, t, d, imax, a, c: integer;

begin
    if auto then begin
        n := random(5000);
        for i := 1 to n do
            soldier[i] := random(5000);
    end
    else begin
        readln(n);
        for i := 1 to n do
            read(soldier[i]);
    end;
   
    {сортирововчка}
    for i := 1 to n - 1 do
    begin
        imax := i;
        for j := i + 1 to n do
            if soldier[j] > soldier[imax] then
                imax := j;
        max := soldier[i];
        soldier[i] := soldier[imax];
        soldier[imax] := max;
    end;
   
    max := 0;
    for i := 1 to n - 1 do
        for j := i + 1 to n do
        begin
            a := soldier[j];
            d := soldier[j] - soldier[i];
            c := 2;
            for k := j + 1 to n do
                if soldier[k] = a + d then begin
                    a := soldier[k];
                    c := c + 1;
                end;
            if c > max then max := c;
        end;
   
    writeln(max);
end.
0,0(0 оценок)
Ответ:
lesyastruklol
17.07.2021 16:49
program SquareRootSum;
        var S: real;
               i: integer;
begin
    i := 5;
    S := 0;
    while S <= 100 do
    begin
        S := S + sqrt(i);
        i := i + 5;
    end;
    WriteLn(S)
end.


program Product;
    var P: real;
        i: integer;
begin
    P := 1;
    i := -10;
    while i <= -1 do
    begin
        P := P*i;
        i := i+1
    end;
    WriteLn(P)
end.

Сумме присваиваем начальное значение 0, потому что мы потом будем прибавлять к ней числа. А произведение присваиваем начальное значение 1 (если был бы 0, то все произведение было бы равно нулю, а нам это не нужно).
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота