denisseleznevdenis
19.02.2021 22:36

Функция range PYTHON, как запросить начало конец и делитель?
Задали написать программу, которая запрашивает у пользователя 3 числа:
начало диапазона
конец диапазона
N
Программа должна выводить все числа кратные N в указанном диапазоне.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hekaterina0606
18.02.2020 16:48
1)uses crt; var  x,a,b,c,i: integer;     begin cls;   write('введите число: '); readln(x);     a: = x div 100;     b: = (x - a*100) div 10;     c: = (x - a*100 - b*10);     if (a=b) or (a=c) or (b=c) then    writeln('есть одинаковые цифры')    else    writeln('одинаковых цифр нет'); end.2)uses crt; var  x: real;     begin cls;   write('сумма покупки: '); readln(x);     if x> 1000 then x: =x-(x*0.1);     writeln('стоимость с учётом возможной скидки ',x); end.
0,0(0 оценок)
Ответ:
Аропахора
26.07.2021 13:20

ответ все этапы технологии решения задачи на компьютере на примере конкретной задачи.

1. Постановка задачи. Дано N кубиков, на которых написаны разные буквы. Сколько различных N -буквенных слов можно составить из этих кубиков (слова не обязательно должны иметь смысл)?

Искомую целочисленную величину обозначим буквой F. Тогда постановка задачи выглядит так:

Дано: N.

Найти: F.

2. Математическая формализация. Получим расчетную формулу. Сначала рассмотрим несколько конкретных примеров. Имеются два кубика с буквами «И» и «К». Ясно, что из них можно составить два слова:

ИК КИ.

Добавим к ним третью букву, «С». Теперь число разных слов будет в три раза больше предыдущего, т. е. равно 6:

ИКС КИС ИСК КСИ СКИ СИК.

Если добавить четвертую букву, например «А», то число слов возрастет в четыре раза и станет равным 24:

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота