Sghem
02.11.2022 20:38

составить программу для сортировки массива данных : пузырьковой, отбора, вставки, шелла и быстрой сортировки. вывести на экран (один раз) и (для каждого из методов) массивы данных. составить сравнительную таблицу эффективности методов, в которой необходимо указать число сравнений и перестановок переменных в каждом методе сортировки.
матрица задается один раз случайным образом, далее она используется для каждого из методов сортировки.
дано:
упорядочить главную диагональ матрицы по возрастанию, данные сверху от главной диагонали упорядочить по убыванию, снизу от главной диагонали по возрастанию. упорядочивание производить по нормали к главной диагонали.
написать на c++

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sashka1611
14.09.2020 04:14
1)когда найдется элемент равный заданому 
2)отсекается 1 элемент
3)Произведение элементов массива, которые лежат в промежутке [40;55)

в паскале как и почти любом ЯП есть переменные,которые содержат имя и значение,например (i: =0)->имя переменной i,значение 0.Значение переменной можно изменить,имя переменной нельзя.Массивы это переменные которые хранят несколько значений.Чтобы обратиться к определенному значению масива использовать синтаксис имямасива[индексмасива],например чтоб получить 3 элемент масива a использовать a[3].repeat  (expression) until(boolean) это цикл,в котором будет выполняться expression(любой код) до тех пор пока boolean не будет верно.Boolean это выражение значение которого будет равно true/false(правда/неправда).Напрмер в repeat 
i:=i+1; 
until (a[i]=x) or (i=10); к переменной i будет прибавляться 1 до тех пор пока a[i] не равно x или i будет меньше 10(так как в масиве всего 10 элементов,если например i будет 11 это будет выход за границу массива).Каждый блок выполнения в цикле(в нашем случае i:=i+1) называется итерацией.В цикле for(a to max) в a идет создание переменной-счетчика(в нашем случае создание переменной i со значением 0) ,потом пишется to и идет максимальное значение счетчика.И итерации этого цикла(if (a[i]=>40) and (a[i]<55) then s:=s*a[i]; 
).В конце каждой итерации автоматически значение счетчика увеличивается на 1.До тех пор пока счетчик меньше или равен max итерации будут выполняться.
А вообще в интернете очень много обучающих статей по данной теме
0,0(0 оценок)
Ответ:
anciferovalex
14.09.2020 04:14

Var

  size: integer;

  counter: integer;

  mas: array of integer;

   

Begin  

  Write('Введите количество чисел в последовательности: ');

  Readln(size);

   

  if (size > 0) then

  begin

     Writeln();

     SetLength(mas, size);

     

     for var i := 0 to size - 1 do

     begin

        Write('Введите ', i + 1, ' число: ');

        Readln(mas[i]);

         

        if ((mas[i] mod 3 = 0) and (mas[i] mod 10 = 2)) then

           counter := counter + 1;

     end;

     

     Writeln();

     Writeln('ответ: ', counter);

  end

   

  else

     Writeln('Количество чисел должно быть больше нуля!');

   

End.


Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, крат
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота