Nyrkoff
21.05.2020 12:58

Паскаль. написать программу нахождения количества элементов массива, значения которых равно 2. если таких чисел в массиве нет, то вывести на экран соответствующее сообщение

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gogamer228
11.10.2020 03:50

Объяснение:

program ArrayOf2;

const

   ArraySize=10; {устанавливаем размер массива}

   MaxRandom=5; {максимальное случайное число для заполнения массива}

var

   x : array[1..ArraySize] of integer;

   i, Sum2 : integer;

begin

   Sum2:=0;

   for i:=1 to ArraySize do x[i]:=Random(MaxRandom); {в цикле заполняем массив случайными числами от 1 до заданной MaxRandom}

   for i:=1 to ArraySize do WriteLn(x[i]); {выводим на печать массив, который получился (в задании это не требовалось, можно убрать эту строку)}

   for i:=1 to ArraySize do if x[i]=2 then Sum2:=Sum2+1; {считаем двойки}

   if

       Sum2 > 0

   then

       Writeln('The quantity of 2 in this array is: ',Sum2)

   else

       WriteLn('No any 2 in this array was found')

end.

0,0(0 оценок)
Ответ:
suslenok91
11.10.2020 03:50

===== PascalABC.NET =====

begin

 var n := ReadInteger('Укажи длину массива:');

 var a := ArrRandom(n, -5, 5);

 var k := a.Println.Count(p -> p = 2);

 if k = 0 then

   Print('Нет элементов, равных 2')

 else

   Print('Число элементов, равных 2:', k)  

end.


Паскаль. написать программу нахождения количества элементов массива, значения которых равно 2. если
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота