alferovasnega
16.01.2022 06:53

Составить программу на языке паскаль которая 1.из слов, "биология", «магазин»,"зоопарк" – составить слово "зоология", зоомагазин, подсчитать сколько в них букв
2. в тексте имеется символ "%", сколько раз он встречается.
3. в тексте удалить все скобки.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Andreораидзпч
08.06.2023 01:12
Код в файлах. Отдельно реализован класс Geometry. Пример работы представлен на скриншоте.

Внимание! Хром жрет строки! Сейчас поправлю

Laboratorna2.cs
//////////////////////////////////////////////////
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace Laboratorna2{
    class Laboratorna2
    {
        public static void A() {
             Console.WriteLine("Привет, это метод А()");
        }
        public static void B(int n, int m) {
             Console.WriteLine(n + m);
             Console.WriteLine(n - m);
             Console.WriteLine(n * m);
             Console.WriteLine(Convert.ToDouble(n) / m);
        }
        public static double C(double k, double l, double m) {
             return (k + l + m) / 3;
        }
  public static string N11(ref int Numb) {
             Numb = 11 * Numb; return "";
  }
  public static int Line(ref string line) {
             char[] arr = line.ToCharArray();
             Array.Reverse(arr);
             line = new string(arr);
             return line.Length;
  }
  static void Main(string[] args) {
             Console.WriteLine("Метод А:"); A();
             Console.WriteLine("Метод B:"); B(5, 7);
             Console.WriteLine("Метод C: {0}", C(4.33, 13.6, -14.88439435));
             Console.WriteLine("Geometry.S: {0}", Geometry.S(5));
             double P, S;
             Geometry.Par(5, out P, out S);
             Console.WriteLine("Geometry.Par: P={0}; S={1}", P, S);
             int N = 7;
             Console.WriteLine("Метод N11: Число = {0}; Результат = {2}", N, N11(ref N), N);
             string kekus = "Lol Kek Cheburek!";
             Console.WriteLine("Метод Line: Исходная строка = \"{0}\"; Длина = {1}; Результирующая строка = \"{2}\";", kekus, Line(ref kekus), kekus);
             Console.ReadKey();
      }
    }
}

Geometry.cs
\\\\\\\\\\\\\\\\\\\\\\\\\
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace Laboratorna2 {
 class Geometry {
  public static double S(double R) {
   return Math.PI * Math.Pow(R, 2);
   }
  public static void Par(double R, out double S, out double P) {
   S = Math.PI * Math.Pow(R, 2);
   P = 2 * Math.PI * R;
  }
 }
}

C# xотя бь| половину. 1. создать класс laboratorna2, который содержит метод main () 2. создать еще т
0,0(0 оценок)
Ответ:
shuraKotokoto
29.08.2022 05:40
1. В системе счисления по основанию n для числа, заканчивающегося цифрой 4, будет верно 256_{10}=an^2+bn+4
Конечно, можно такое уравнение решить методом подбора, но это неэффективно.
Минимальное четырехзначное число в системе счисления по любому основанию n записывается как 1000 и оно равно n³. Найдем это n для случая, когда наше число 256 станет четырехзначным: n=∛256 ≈ 6.35.
Следовательно, n не может быть меньше 7.
Вспомним, как мы переводим число из десятичной системы счисления в систему по основанию n. Мы делим наше число "в столбик" на основание системы n, потом записываем остаток, частное снова делим... А в конце к результату приписываем остатки в обратном порядке. Последней цифрой числа буде как раз остаток от первого деления. А у нас по условию он равен 4. Т.е. когда мы разделим 256 на n, то остаток будет равен 4. Тогда число на 4 меньшее, чем 256, должно делиться на n нацело. Начинаем работать с числом 265-4=252.
Разложим его на простые множители: 256=1х2х2х3х3х7. Мы выше отметили, что основание системы n не может быть меньше 7. А у нас как раз есть семерка среди делителей. Попробуем перевести 256 в систему счисления по основанию 7:
256 / 7 = 36, остаток 4 (кто бы сомневался!)
36 / 7 = 5, остаток 1.
Записываем результат: 514₇
И проверяем наше самое первое уравнение.
5х7²+1х7¹+4=5х49+7+4=245+11=256₁₀.
ответ: минимально возможное основание системы счисления- 7

2. 100₇+х=230₅
Поскольку про систему счисления х ничего не сказано, считаем, что она десятичная. Переводим все в десятичную систему и решаем уравнение.
100₇=1х7²=49; 230₅=2х5²+3х5=50+15=65;
49+х=65 ⇒ х=65-49=16
ответ: х=16

3. Вспоминаем написанное в первой задаче. Если число в некоторой системе счисления оканчивается на 5, то оно дает 5 в остатке при делении на основание этой системы счисления. Тогда числа 56-5=51 и 124-5=119 должны делиться нацело на основание системы счисления.
51=1х3х17; 119=1х7х17
НОД обоих чисел равен 17 - это и есть основание системы счисления.
ответ: основание системы счисления равно 17

4. Определение количества единиц в двоичной записи числа
n=8^{1014}-2^{520}-12=2^{3\cdot1014}-2^{520}-12=2^{3042}-2^{520}-12
Число 2³⁰⁴² в двоичной системе будет представляться единицей с 3042 нулями. Число 2⁵³⁰ - соответственно единицей с 530 нулями. Вполне понятно, что последние 530 нулей в результате так нулями и останутся. А вот из 531-го справа нуля нужно будет вычитать единицу. как всегда, придется "занимать" единичку из старших разрядов. Для понимания происходящего рассмотрим более короткий пример:
   1000000
-        1000
--------------
      111000
Мы видим, что начиная с позиции единичного разряда в вычитаемом слева каждый ноль заменился на единицу. В нашем случае в позициях с 531 по 3042 появятся единицы. Их будет 3042-531+1=2512.
Осталось вычесть из результата 12₁₀=1100₂. Тоже посмотрим на "коротком" примере:
   100000000
-            1100
-----------------
      11110100
В исходном числе была одна единица, а в результате их стало на три меньше, чем было нулей. У нас нулей было 530, следовательно, вместо них станет 530-3=527 единиц
А всего в числе будет 2512+527-1=3038 единиц. Почему отняли одну? Мы ведь для второго вычитания должны были единичку "занять". Вот и получился среди единичек в далеком 531-м разряде ноль.
ответ: 3038 единиц
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота