lyuda00777
16.08.2021 20:24

Информатика
написать программу на си шарп

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

№1)

16 бит = 16 / 8 байт = 2 байта

64 байта = 64 * 8 байта = 512 бит

1 Кб = 1024 байт = 8 * 1024 бит = 8192 бит

2560 байт = 2560 / 1024 Кб = 2,5 Кб ≈ 0,00241 Мб

2 Гб = 1024 * 2 Мб = 2048 Мб

№2)

200 байт ≈ 0,1953 Кб

0,1953 Кб > 0,25 Кб => 200 байт > 0,25 Кб

1536 байт = 1,5 Кб

1,5 Кб = 1,5 Кб => 1536 байт = 1,5 Кб

3 байта = 3*8 бит = 24 бит

24 бит = 24 бит => 3 байта = 24 бита

1000 бит = 125 байт = 0,122 Кб

0,122 Кб < 1 Кб => 1000 бит < 1 Кб

№3)

1) 2 Мб = 2048 Кб

2048 / 100 ≈ 20 файлов можно разместить на дискете

2) 4 Мб = 4096 Кб

4096 / 100 ≈ 40 файлов можно разместить на дискете

0,0(0 оценок)
Ответ:
svetlana485
14.01.2020 00:42

--- Python 3.8.3 ---

import typing

from typing import List  

from typing import AnyStr

from typing import Tuple

from typing import Callable

from typing import Any

class FactPackLoader:

   def __init__(self, TrueCode: str = '1', FalseCode: str = '0', encoding: AnyStr = 'utf-8',):

       self._encoding = encoding

       self._trueAnswCode = TrueCode

       self._falseAnswCode = FalseCode

   def LoadPack(self, FactPackPath: AnyStr, AnswSplitter: AnyStr = ':: ') -> Tuple[AnyStr, int]:

       with open(FactPackPath, 'r', encoding=self._encoding) as data:

           RawData = data.read().split('\n')

       for FactPair in RawData:

           FactPair = tuple(FactPair.split(AnswSplitter))

           yield (FactPair[0], self._ToBool(FactPair[1]))

           

   def _ToBool(self, replyCode):

       if replyCode == self._trueAnswCode: return True

       return False  

def main():

   f = FactPackLoader()

   print('"Правда-Ложь"\nАвтор: KnowsUser1\nVersion: 0.0.1 Ya-Sdelyal')

   IsGameRunning = 'y'

   while IsGameRunning == 'y':

       lives = 3

       fp = input('Укажите имя файла, содержащего пак фактов:\n')

       facts = f.LoadPack(fp)

       for i, Q in enumerate(facts):

           print(f'Вопрос {i+1}:\n{Q[0]}')

           reply = True if input().lower() == 'да' else False

           if reply != Q[1]:

               lives -= 1

               print(f'Вы не поверите, но тот факт, что {Q[0]}, действительно является правдой!\nЖизней осталось: {lives}')

           else:

               print(f'Вы совершенно правы!')

           if lives <= 0:

               print('Вы проиграли')

               IsGameRunning = input('Попробуем ещё раз? Y/N\n').lower()

               break

       else:

           print('Поздравляем, вы успешно выполнили все задания из файла!')

           IsGameRunning = input('Сыграем ещё раз? Y/N\n').lower()

if __name__ == "__main__":

   main()

В файле с паком вопросов после каждого вопроса должен быть указан код ответа (по умолчанию - 1 - истина, 0 - ложь), отделённый от вопроса особым символом/набором символов (по умолчанию - ':: ')

Коды ответа при необходимости в изменении указываются при создании экземпляра FactPackLoader(), символ-разделитель - при вызове LoadPack().

По умолчанию в файле с заданиями пара вопрос ответ выглядит так:

//facts.txt

На самом деле солнце белого цвета :: 1

После "::" должен стоять пробел

P.S - Код main() можно и нужно рефакторить, ибо сейчас это нечто страшное.

P.S 2 Да, я часто обращаю внимание на плохой код людей, а сейчас сам его написал. Вынепонимаете, этодругое =))

P.S 3 Проверял, программа работает. Если что то сломалось, виноват сайт. На всякий случай прикреплю файл исходного кода в .txt

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота