Dirolling
27.08.2021 04:10

Создать массив о работниках из пяти записей следующего вида табельный номер (2 байта), фамилия (25 байт), пол (1 байт), количество детей (1 байт). написать программу на языке ассемблер которая помещает в стек табельные номера работников женщин имеющих детей

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
gennadih90
23.03.2022 14:55

#include <iostream>

using namespace std;

int main()

{

int YBorn , YNow ;

cout <<"what year where you born in?"<<endl;

cin >>YBorn;

cout <<"what year is it now?"<<endl;

cin >>YNow;

int YOld=YNow-YBorn;

cout<<"at the end of the year:"<<endl;

cout << "you're " <<YOld << " years old"<<endl;

int MOld = YOld*12;

cout<< "and "<<MOld<<" month old"<<endl;

int DOld=YNow/4-YBorn/4+YOld*365;

cout<<"and "<<DOld<<" days old"<<endl;

int HOld=DOld*24;

cout<<"and "<<HOld<<" hours old"<<endl;

int MinOld=HOld*60;

cout<<"and "<<MinOld<<" minutes old"<<endl;

int SOld=MinOld*60;

cout<<"and "<<SOld<<" seconds old"<<endl;

cout<<"and "<<SOld<<"000 miliseconds old"<<endl;

system("pause");

return 0;

}

0,0(0 оценок)
Ответ:
galinaegi2
18.02.2022 07:22

Создать файл X компонентами которого являются элемента массива M. Переписать из файла X в файл Y все компоненты, которые стоят на четных местах. Прочитать файл Y.

M = (0,1; 5,6; 0.8; 2,4; 7,3; 6,8; 0,5; 2,3;)

Решение

 

Описание переменных:  

M - массив-константа;

x, y - переменные, связанные с типизированными файлами;

n - считанное из файла очередное число;

i - счетчик.

Алгоритм решения задачи:  

Создать константу-массив, присвоив ей заданные значения массива.

Связать файловые переменные с соответствующими файлами.

Открыть файл X на запись. Записать в него все элементы массива. Закрыть файл.

Открыть файл X на чтение, а файл Y на запись. Присвоить счетчику значение 1. Пока не будет достигнут конец файла X, считывать из него очередное число. Если при этом счетчик имеет четное значение, то записывать число в файл Y. После считывания и проверки на четность номера очередного числа, увеличивать счетчик на 1. После того как файл X будет прочитан, закрыть оба файла.

Открыть файл Y на чтение. Пока не будет достигнут его конец, считывать из него очередное число и выводить его на экран. После завершения цикла закрыть файл.

Программа на языке Паскаль:  

 

const M: array[1..8] of real = (0.1, 5.6, 0.8, 2.4, 7.3, 6.8, 0.5, 2.3);

var  

   x,y : file of real;

   n: real;

   i: byte;

begin

   assign(x,'x.dat');

   assign(y,'y.dat');

 

   rewrite(x);

   for i:=1 to 8 do

       write(x, M[i]);

   close(x);

 

   reset(x);

   rewrite(y);

   i := 1;

   while not EOF(x) do begin

       read(x, n);

       if not odd(i) then

           write(y, n);

       i := i + 1;

   end;

   close(x);

   close(y);

 

   reset(y);

   while not EOF(y) do begin

       read(y, n);

       write(n:5:1);

   end;

   writeln;

   close(y);

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота