mwdep08pan
21.03.2023 03:28

Составьте программу пайтон с использованием одной функции с переменным количеством аргументов для вычисления сумм чисел 1, 3, 5, 7, 9 и 6, 8, 10.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Котя5461
04.08.2022 20:54
Const
  m1 = 10;
  n1 = 8;
var
  x: array[1..m1, 1..n1] of integer;
  i, j, m, n, t: integer;
begin
  Write('Введите через пробел число строк и столбцов матрицы: ');
  Read(m,n);
  Randomize;
  Writeln('Исходная матрица');
  for i:= 1 to m do begin
    for j:=1 to n do begin
      x[i,j]:= Random(50)+1;
      Write(x[i,j]:3)
    end;
    Writeln
  end;
  { простая обменная сортировка первого столбца }
  for i:=1 to m-1 do
    for j:=1 to m-1 do
      if x[j,1]>x[j+1,1] then
      begin t:=x[j,1]; x[j,1]:=x[j+1,1]; x[j+1,1]:=t end;
  Writeln('Результирующая матрица');
  for i:= 1 to m do begin
    for j:=1 to n do Write(x[i,j]:3);
    Writeln
  end
end.

Тестовое решение:
Введите через пробел число строк и столбцов матрицы: 10 8
Исходная матрица
 44 28 35 45 28 21 24 31
 39 10  1 27 33  3  7 39
 22  8 45  4 33 11 23 37
 18 50 48 12 45 28  1 32
  3 25 45 11 40 49 47 17
 28 16 46 43 11 13 22 18
 27 24 45 33 44 44 34 34
  6 49 27 28 24 13 37 12
  9 19 25  8  8 47 49 24
 11 29 26 18 16 30 27  6
Результирующая матрица
  3 28 35 45 28 21 24 31
  6 10  1 27 33  3  7 39
  9  8 45  4 33 11 23 37
 11 50 48 12 45 28  1 32
 18 25 45 11 40 49 47 17
 22 16 46 43 11 13 22 18
 27 24 45 33 44 44 34 34
 28 49 27 28 24 13 37 12
 39 19 25  8  8 47 49 24
 44 29 26 18 16 30 27  6
0,0(0 оценок)
Ответ:
davidkhatkin
06.05.2023 07:56
//PascalABC.Net 3.0, сборка 1053
const
 BMW=1700000;
var
  s,x:longint;
  n:byte;
begin
  Randomize;
  n:=0; s:=0;
  Writeln('Месяц   Сумма взятки   Накоплено');
  while s<BMW do begin
    x:=Random(150001); s:=s+x; Inc(n);
    Writeln(n:4,x:12,s:15)
  end;
  Writeln('Потребуется месяцев: ',n)
end.

Тестовое решение:
Месяц   Сумма взятки   Накоплено
   1      131598         131598
   2       40502         172100
   3       90384         262484
   4       33945         296429
   5       50956         347385
   6      137449         484834
   7       32050         516884
   8       68439         585323
   9        1187         586510
  10       70707         657217
  11      145871         803088
  12      143780         946868
  13       54179        1001047
  14       39314        1040361
  15       30297        1070658
  16       49163        1119821
  17       63244        1183065
  18      128362        1311427
  19       87284        1398711
  20       80851        1479562
  21       71269        1550831
  22      139577        1690408
  23       78690        1769098
Потребуется месяцев: 23
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота