sayhun
17.09.2021 22:11

И. напишите программу на pascale, которая по введённым координатам точки на плоскости (x,y) определяет, принадлежит точка заштрихованной фигуре или нет

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
chalenkotaya
12.11.2020 12:27
     Мой любимый предмет это - информатика!
На уроках информатики мы познаём компьтерный мир. Сотни программ созданны для нашего поколения чтобы создавать различные презентации, мультфильмы, анимации, рисунки и много всего другого, что так-же нам интересно!
     Если почитать в интернете о данной науке, то мы можем сразу сделать вывод, что на самом деле придуманно очень большое кол-во программ и приложений. Мы можем узнать погоду, написать сочинение или реферат, подготовить презентацию, отправить любой файл через доступные приложения и программы, как на компьтере так и на телефоне, а самое главное всё отправляется в один миг - и получатель сообщения  может сразу воспользоваться файлом. Существую так-же различные  форматы файлов, для удобствия получать на любом устройстве.
     Насчёт данной науки я могу сказать так: наша цивилизация развивается очень быстро и в этом ей информатика!
0,0(0 оценок)
Ответ:
Milintin25
27.11.2022 05:32

Сделай импорт файла в любой удобный для тебя интерпритатор

Далее задай путь и сделай переменную, равную символам в файле

path = 'ПУТЬ'

string = open(path).readline()

далее перебери символы в файле по условию, задай 2 новых переменных k и maximum, где maximum будет максимальной подстроки

k = 0

maximum = 0

for sym in string:

  if sym == 'A' or sym == 'B' or sym == 'C':

     k += 1

     if k > maximum:

        maximum = k

  else:

     k = 0

print(maximum)

результатом выведется максимальная длинна такой подстроки

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота