295f9gh
25.03.2021 03:38

Написать программу на ! 25
найдите и выведите на экран все двузначные числа , у которых при умножении на 2 ,сумма цифр увеличивается на 5

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yarlev88
04.11.2022 21:43

Если у вас есть изображения, которые занимают много места на диске, их размеры можно уменьшить, не изменяя размер изображения. Наилучшее сжатие достигается форматом JPG, но даже если изображение уже в этом формате, его всё равно можно уменьшить, так как у формата JPG есть адаптивная схема сжатия, позволяющая сохранять изоражение с разной степенью сжатия. Компромис здесь заключается в том, что чем меньше места занимает изображение, тем больше деталей теряется при сжатии. Нужно также помнить, что повторные сохранения в формате JPG также приводят к ухудшению качества изображения.


0,0(0 оценок)
Ответ:
asdgvhmh
01.10.2020 18:31
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var a0:=a[0];
  var b:=a[1:].Where(x->x mod a0=0).ToArray;
  if b.Length>0 then b.Println
  else Writeln('Нет элементов, кратных первому');
end.

Пример
n= 16
-11 85 11 -9 -24 32 6 42 -92 -69 -87 2 -11 -77 -94 66
11 -11 -77 66

Замечание.
Если первый элемент тоже нужно включить в результирующий массив,
нужно записать так: var b:=Where(x->x mod a0=0).ToArray;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота