yuraaverchenko
26.02.2022 02:38

Написать программу, которая определяет сколько единиц в числе, которое ввёл пользователь. например, в числе 197313 – две единицы. ( циклом)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pechka509
11.10.2020 03:05

program p1;

var n,k1:integer;

begin

k1:=0;

write ('Введите число ');

readln (n);

write ('Количество единиц в числе ',n,' равно ');

repeat

if n mod 10 = 1 then k1:=k1+1;

n:=n div 10;

until n=0;

write(k1);

end.

0,0(0 оценок)
Ответ:
kelaruu
11.10.2020 03:05

На python:

Объяснение:

a = input("Введите число: ")

b = 0

for i in list(a):

   if i == '1':

       b += 1

print("'1' - ", b)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота