baburina56vValiabab
22.08.2021 00:27

По информатике. составить программу дано предложение. заменить все включения "ма" на "мо"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Relig1d
31.12.2021 01:16
В двоичной системе: 1243(10)=2^10+2^7+2^6+2^4+2^3+2^1+1 = 1024+128+64+16+8+2+1 = 1243(10) =10011011011(2)
В восьмиричной системе:  разбиваете двоичное представление на группы по 3 бита справа налево
011  = 3
011  = 3
011  = 3
10   = 2
Тогда в восьмиричной системе: 2333(8) = 2*8^3+3*8^2+3*8^1+3 = 1024+192+24+3=1243(10)
В шестнадцатиричной системе:  разбиваете двоичное представление на группы по 4 бита справа налево
1011 = B = 11(10)
1101 = D(16) = 13(10)
100  = 4
Тогда в шестнадцатиричной системе
4DB(16) = 4*16^2+13*16^1+11 =1024+208+11=1243(10)
0,0(0 оценок)
Ответ:
1221081056
30.06.2022 20:38
// PascalABC.Net 3.0, сборка 1088
const
  n=30;
var
  a:array[1..n] of integer;
  i,k:integer;
begin
  Randomize;
  Writeln('*** Исходный массив ***');
  k:=0;
  for i:=1 to n do begin
    a[i]:=Random(1001);
    Write(a[i],' ');
    if (a[i] mod 3 = 0) and (a[i] mod 10 = 1) then Inc(k)
  end;
  Writeln;
  Writeln('Количество найденных элементов равно ',k)
end.

Тестовое решение:
*** Исходный массив ***
503 187 764 452 351 819 339 940 681 369 938 874 639 212 633 825 983 830 121 801 889 36 479 14 357 382 631 8 402 61
Количество найденных элементов равно 3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота