Reolgjbjgjff
06.06.2021 02:45

Напишите

составить программу, которая вычисляет и выводит на экран 20% (вывод а) от стоимости покупки с, вводимой с клавиатуры( ввод с)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Лёлик8881
04.06.2023 11:00

В данном случае источником информации можно рассмотреть как Себя так и телефон. Если Я источник информации, то кодирующим устройством будет телефон, каналом связи - электромагнитные волны, декодером - телефон друга, приемником - друг.

Если же передачиком будет мой телефон, то кодировщиком - плата телефона, каналом связи так же - электромагнитные волны, декодировать будет плата телефона друга, а приемником тогда будет телефон друга.

Может немного сумбурно, но посмортрите, как Вы разбирали на уроках и выберите нужный ответ.

 

0,0(0 оценок)
Ответ:
longassride
20.09.2022 00:27
// PascalABC.NET 3.0, сборка 1150 от 22.01.2016
begin
  var n:=ReadInteger('Количество элементов массива ');
  var m:=ArrRandom(n,-50,50); m.Println(', ');
  var a:=0; var b:=0; var c:=0;
  for var i:=0 to n-1 do begin
    if m[i]>0 then a:=a+m[i];
    if m[i]<m[b] then b:=i;
    if m[i] mod 5 = 0 then Inc(c)
  end;
  var w:=(b+1)+a/(c+1);
  WritelnFormat('A={0}, B={1}, C={2}, W={3}',a,b+1,c,w);
  Writeln('Принято, что элементы массива нумеруются от единицы')
end.

Тестовое решение:
Количество элементов массива  13
-43, -15, 18, -8, -13, -47, -36, 6, -16, 45, 33, 33, -24
A=135, B=6, C=2, W=51
Принято, что элементы массива нумеруются от единицы

Составить программу вычисления, w = b + a - сумма положительных элементов массива; b – номер наимень
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота