Nicktat
01.07.2021 09:36

Напишите программу (в паскаль), которая выведет на печать сумму четных цифр числа и сумму нечетных цифр числа. программа получает на вход натуральное число.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
samaya2009
11.10.2020 02:34

Объяснение:

Var s,n:integer;

Begin

   write('Введите число: ');readln(n);

   s:=0;

   While n<>0 do

    Begin

     if n mod 10 mod 2 = 0 then s:=s+n mod 10;

     n:=n div 10;

    End;

   if s<>0 then writeln('Сумма четных цифр: ',s)

    else writeln('Нету четных цифр в числе');

   readln;

End.

Может быть неправильной.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота