klikedfrite
07.03.2023 05:22

Робот кумир решите второе или третье

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
МАРИЯpahal
16.08.2021 20:55

0.04.2020

Сообщений: 6

1

Количество маршрутов в прямоугольной таблице

10.05.2020, 18:11. Просмотров 6573. ответов 4

Метки нет (Все метки)

приветствую вас, участники форума!

очень нуждаюсь в вашей в решении задачи на сайте Сириус.

Задание

В прямоугольной таблице N×M вначале игрок находится в левой верхней клетке. За один ход ему разрешается перемещаться в соседнюю клетку либо вправо, либо вниз (влево и вверх перемещаться запрещено). Посчитайте, сколько есть у игрока попасть в правую нижнюю клетку.

Входные данные

Вводятся два числа N и M — размеры таблицы 1≤N≤10,1≤M≤10.

Выходные данные

Выведите искомое количество .

Пример

Ввод

1 10

Вывод

1

Решения, которые работают, но на сколько верно и сайт (Сириус) их не принимает.

№1

PythonВыделить код

1

2

3

4

5

6

7

n, m = map(int,input().split())

F = [[0]*(m+1) for i in range (n+1)]

F[1][1] = 1

for i in range (2, n+1):

for j in range (2, m+1):

F[i][j] = F[i-1][j-2]+[i-2][j-1]

print (F[n][m])

№2

PythonВыделить код

1

2

3

4

5

from math import factorial

N = int(input())-1

M = int(input())-1

res = factorial(N+M)//(factorial(N)*factorial(M))

print(res)

0,0(0 оценок)
Ответ:
abeloglazova891
11.12.2020 16:48

import random

A  = []

for i in range(15):

   A.append(random.randrange(-50,50))

print(A)

pr = 1

for i in range(len(A)):

   pr*= A[i]

print("Произведение всех элементов равно: ", pr)

ko = 0

for i in range(len(A)):

   if A[i] < 0:

       ko += 1

print("Количество отрицательных элементов: ", ko)

sn = 0

nch = 0

for i in range(15):

   if A[i] % 2 != 0:

       sn+= A[i]

       nch += 1

if nch == 0:

   print("NO")

else:

   sr = sn / nch

   print("Среднее арифметическое:", end=" ")

   print(float('{:.2f}'.format(sr)))

print("Положительные, которые оканчиваются на 8:", end= " ")

k8 = 0

k93 = 0

for i in range(len(A)):

   if A[i] > 0 and A[i] % 10 == 8:

       k8 += 1

       print(A[i],end=" ")

if k8 == 0:

   print("NO",sep=" ")

print("Числа, которые делятся на 3, но не на 9:")

for i in range(len(A)):

   if A[i] % 3 == 0 and A[i] % 9 != 0 and A[i] > 0:

       k93+=1

       print(A[i],end=" ")

if k93 == 0:

   print("NO")

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота