Aldiyar26
12.06.2020 02:34

Написать программу (pascal)и алгоритмы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
юююю20
20.07.2022 07:12

1:

program prog;

var i,n,s,a:integer;

var chk:boolean;

begin

   chk:=False;

   s:=1;

   write('Введите количество вводимых чисел: '); readln(n);

   for i:=1 to n do

   begin

       write('Введите ', i, '-е число: '); readln(a);

       if i mod 2 = 0 then

       begin

           s:=s*a;

           chk:=True;

       end;

   end;

   if chk = False then s:=0;

   write('Произведение чётных членов введённой последовательности равно ', s);

end.

2:

program fib;

var

   F1,F2,n,i :Integer;

begin

   write('Введите количество чисел Фибоначчи: '); readln(n);

   F1:=1;

   F2:=1;

   For i:=1 to n do

   begin

       if i>2 then

       begin

           F1:=F1+F2;

           F2:=F1-F2;

       end;

       write(F1, ' ');

   end;

end.

0,0(0 оценок)
Ответ:
zdavatelzno
11.04.2022 16:00

Program Randomizer;

Var a,b,i : Integer;

Const n = 5;//Кол-во попыток

 Begin  

  WriteLn('                Вас приветствует "Randomizer!™"');

  ReadLn;

  WriteLn('    Компьютер загадал число от 1 до 100, ваша задача отгадать его.');

  WriteLn('                   Приступим!(Нажмите Enter)');

  ReadLn;

  WriteLn('                         Введите число');

  i:= 1;

  a:=random(100);

  While ((b <> a) and (i < n + 1)) do //Программа не завершится, пока b не станет равной a или n (попытки) не закончатся.  

   Begin

    //If b > 100 then WriteLn('Ошибка - число превышает 100');//Нужно, чтобы при вылете ошибки программа не завершалась и попытки не уменьшались.

    ReadLn(b);

    If b = a then WriteLn('Вы угадали!') Else

    If ((b <> a) and (i <> n)) then WriteLn('Попробуйте другое число...') Else  WriteLn('          Попытки закончились! Перезапустите программу.');

    inc (i);

   End;

 End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота