неизвесный1
14.07.2021 15:49

Выполните два .язык паскаль

№1)дано четырёхзначное число.найти сумму цифр стоящих на нечётных местах

№2)дано целое число n.вычислить:

(-1,если n-чётное

y= (0,если n=0

(1,если n нечётное

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SkiJu
17.04.2022 18:20

program a2;

var

 a, x1, y1, z1, l1, z, l: string;

 i, g, d, f, a1, b1, sum, vr, vr1, err: int64;

begin

 readln(a);

 g := pos(';', a);

 x1 := copy(a, 2, g - 2);

 y1 := copy(a, g + 2, length(a) - g - 2);

 if a[1] = '[' then d := 1

 else d := 0;

 if a[length(a)] = ']' then f := 1

 else f := 0;

 if pos('/', x1) <> 0 then begin

   z := copy(x1, 1, pos('/', x1) - 1);

   z1 := copy(x1, pos('/', x1) + 1, length(x1) - pos('/', x1));

   val(z, vr, err);

   val(z1, vr1, err);

   a1 := vr div vr1;

 end

 else val(x1, a1, err);

 if pos('/', y1) <> 0 then begin

   l := copy(y1, 1, pos('/', y1) - 1);

   l1 := copy(y1, pos('/', y1) + 1, length(y1) - pos('/', y1));

   val(l, vr, err);

   val(l1, vr1, err);

   b1 := vr div vr1;

 end

 else val(y1, b1, err);

 for i := a1 to b1 do sum := sum + 1;

 val(z, vr, err);

 val(z1, vr1, err);

 if (d = 0) then  

   if vr = 0 then sum := sum - 1

   else if (vr mod vr1 = 0) then sum := sum - 1;

 val(l, vr, err);

 val(l1, vr1, err);

 if (f = 0) then  

   if vr = 0 then sum := sum - 1

   else if (vr mod vr1 = 0) then sum := sum - 1;

 writeln(sum);

end.

На не благодари)

0,0(0 оценок)
Ответ:
HiDolr
08.09.2020 04:05

program z1;//имя программы

var a:real;b,c,d:integer;//объявление глобальных переменных

function M (x,y:integer): integer;//название функции, параметры, тип результата

begin//тело функции

if x>y then M:=x else M:=y//неполный условный оператор

end;

begin//тело программы

read (a,b);//ввод значений переменных

if frac(a) >= 0.5 then c:=trunc(a)+1 else c:=trunc(a);//математическое округление

d:= M (b,c);//вызов функции

write(d)//вывод результата

end.

Объяснение:

картинка 1 - блок-схема программы

картинка 2 - блок-схема функции

математическое округление, чтобы 2,5 было равно 3, а не 2 как при использовании функции round


Вводится два числа: первое вещественного типа а второе – целого. Написать программу поиска максимума
Вводится два числа: первое вещественного типа а второе – целого. Написать программу поиска максимума
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота