Катя111111177796
04.07.2021 07:25

Напишите программу на python,мне нужен именно он. за ,если откликнулись!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
саша4278
13.05.2021 14:05

Для Python:

def UnitsConversion():

   n = int(input("Введите число для конвертации: "))

   rule = str(input("Нажмите 1, чтобы конвертировать в килобайты и 2, \

чтобы конвертировать в гигабайты: "))

   if rule == "1":

       m = n*1024

       print(m)

   else:

       m = n/1024

       print(m)

Объяснение:

1)Объявляем функцию UnitsConversion (можно назвать как угодно, без параметров в данном случае);

2)Ждем ввода пользователя при и сразу же конвертируем ввод в число при чтобы Питон мог совершать над ним мат. операции;

3)Спрашиваем, что нужно сделать: перемножить или поделить. В качестве ответа ждем строку, состоящую из "1" или "2", конвертируется ввод в строку при Если не использовать str(), то по умолчанию input() всегда будет строкой, но чтобы не путаться в данном примере, я использовал str().

4)Проверяем условия: если ввод был 1, то m будет произведение чисел, если не 1, то деление чисел, и также вывод ответа с

0,0(0 оценок)
Ответ:
Anonim1678
01.01.2022 03:57
Номер 1.
256000*64=16384000бит
16384000:8=2048000Байт
2048000:1024=2000КБайт
ответ: 2000КБ
Номер 2.
E:\БАЙКАЛ\ВЕТРЫ\Баргузин.bmp. 
в каталоге БАЙКАЛ был создан подкатолог ВЕТРЫ, значит первоначальный путь был таким Е:\БАЙКАЛ\Баргузин.bmp.
Номер 3.
V = K * I, где V - объем; K - размер изображения; I - количество бит. N = 2^i, где N - количество цветов.N = 2^i.256 = 2^i.I = 8 бит.V = K * I = (1920*1080*8)/2^13 = (2^7 * 15 * 2^3 * 135 * 2^3)/2^13 = (2^13 * 2025)/2^13 = 2025КБайт
Номер 4.
k=4*32*64=8192
b=8192*8бит=65536бит
65536:8=8192Байт
8192:1024=8КБайт
Номер 5.
К1=32*64=2048
К2=64*128=8192
i1=8192*16=131072бит
i2=4096*1Байт=4096Байт*8=32768бит
i=i1+i2=131072+32768=163840бит=20480Байт=20КБайт
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота