Zhenya2099
03.07.2021 09:13

C#
напишите программу, которая вычисляет сумму элементов матрицы.

входные данные

в первой строке записаны через пробел размеры матрицы: количество строк n и количество столбцов m ( 1 ≤ n , m ≤ 100 ). в следующих n строках записаны строки матрицы, в каждой – по m натуральных чисел, разделённых пробелами.

выходные данные

программа должна вывести одно число – сумму элементов матрицы.

примеры

входные данные

4 5

1 2 3 4 5

6 12 8 9 10

11 12 12 14 15

16 17 18 12 20

выходные данные

207

программа на c#

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Alexandra0606
11.10.2020 00:18

using System;

namespace ConsoleApp18

{

   class Program

   {

       static void Main(string[] args)

       {

           string s = Console.ReadLine();

           int n = int.Parse(s.Split(' ')[0]), m = int.Parse(s.Split(' ')[1]), sum = 0;

           int[,] a = new int[n,m];

           for (int i = 0; i < n; i++)

           {

               s = Console.ReadLine();

               for (int j = 0; j < m; j++)

               {

                   a[i, j] = int.Parse(s.Split(' ')[j]);

                   sum += a[i, j];

               }

           }

           Console.WriteLine(sum);

           Console.ReadKey();

       }

   }

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота