mihailova1999
06.01.2022 10:19

Напишите программу на ассемблере (tasm).

даны натуральное число n, символы s1, s2, sn. преобразовать последовательность s1, s2, sn, изменив в ней все восклицательные знаки на точки. строку символов ввести с клавиатуры, результат вывести на экран.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladyulin
29.04.2021 23:44
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
0,0(0 оценок)
Ответ:
Sanya055
19.02.2023 00:53

Проверено - работает на Паскаль АВС

 

Program mashaaq;
uses crt;
const n=12;
const m=15;
var
  a:array[1..n,1..m] of integer;
  b:array[1..n] of integer;
  i,j,minus : integer;
begin
  Randomize;
  for i:=1 to n do
    for j:=1 to m do
      a[i,j]:= Random(101)-50; //заполняем массив случайными числами
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  for i:=1 to n do //просматриваем строки сверху вниз
    begin
      minus:=0;
      for j:=1 to m do //просматриваем строку
        if a[i,j]<0  then minus:=minus+1; //если найден отрицательный элемент, увеличиваем счётчик minus на единицу
      b[i]:=minus; //сохраняем значение счётчика для i-й строки
    end;
  writeln;
  {выводим матрицу А и вектор результатов В}

  {в красивой рамочке :)}
  writeln('');
  writeln('*                              Массив                           * Вектор *');
  writeln('');
  for i:=1 to n do
    begin
      write ('* ');
      for j:=1 to m do
        write(a[i,j]:4); //выводим строку массива
      writeln('  *   ',b[i]:2,'   *');  //дописываем справа значение вектора В для этой строки
    end;  
  writeln('');
end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота