gusaka
10.03.2023 05:45

Паскаль. напишите программу, которая составит из цифр 3,4,5,6 все возможные комбинации и проверит каждую из них, является ли она точным квадратом.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
biobiobio
13.02.2023 20:01

В скобках систмы счисления. 8в1 это восемь в первой степени

3.

135(8) = 5*8в0 + 3*8в1 + 1*8в2 = 5+24+64=93

4.

110001001111 = делим на тетраеды

1100  0100   1111

переводим каждую отдельно в десятичную

1100 = 0*2в0 + 0*2в1 + 1*2в2 * 1*2в3 = 0+0+4+8 = 12

12 в 16тиричной систме записывается буквой С


0100 = 0*2в0 + 0*2в1 + 1*2в2 + 0*2в3 = 0+0+4+0 = 4

в 16тиричной записывается как 4


1111 = 1*2в0 + 1*2в1 + 1*2в2 + 1*2в3 = 1+2+4+8 = 15

в 16тиричной это записывается как F

Итого число получается - С4F


5.

110001001111(2) = 1*2в0 + 1*2в1 + 1*2в2 + 1*2в3 + 1*2в6 + 1*2в10 + 1*2в11 = 1+2+4+8+64+1024+2048 = 3151



1. выполните сложение в двоичной системе счисления: 101112 + 1011102 результат запишите в двоичной с
0,0(0 оценок)
Ответ:
muratov20011
13.03.2021 15:14

1)

var

  a, b, s : real;

begin

  read (a, b);

  s := a * b;

  write (s:10:4);

end.

 

2)

var

  a, b, c, k : integer;

begin

  read (a, b, c);

  k := 0;

  if a > 0 then inc (k);

  if b > 0 then inc (k);

  if c > 0 then inc (k);

  writeln (k);

end.

 

3)

var

  a : integer;

begin

  read (a);

  writeln ((a mod 10) * (a mod 100 div 10) * (a div 100 mod 10) * (a div 1000));

end.

 

4)

var

  c, n : integer;

begin

  read (n);

  c := 0;

  repeat

    inc (c);

    n := n div 10;

  until n = 0;

  writeln (c);

end.

 

5)

var

  n, sum, i : integer;

begin

  read (n);

  sum := 0;

  for i := 1 to n do

    sum := sum + i;

  writeln (sum);

end.

 

6)

var

  d, n, k : integer;

begin

  read (n, k);

  d := 0;

  while n >= k do

  begin

    d := d + 1;

    n := n - k;

  end;

  writeln ('n div k = ', d);

  writeln ('n mod k = ', n);

end.

 

7)

var

  n, sum, i, tmp : integer;

begin

  read (n);

  sum := 0;

  for i := 1 to n do

  begin

    read (tmp);

    sum := sum + tmp;

  end;

  writeln (sum / n);

end.

 

8)

var

  i, n, s : integer;

  a : array [1..1000] of integer;

begin

  s := 2;

  read (n);

  for i := 1 to n do

  begin

    a[i] := s;

    s := s + 2 * i + 1;

  end;

  for i := 1 to n do write (a[i], ' ');

end.

 

9)

var

  n, i, count, tmp : integer;

begin

  read (n);

  count := 0;

  for i := 1 to n do

  begin

    read (tmp);

    if tmp < 0 then inc (count);

  end;

  writeln (count);

end.

 

10)

var

  n, i, j : integer;

begin

  read (n);

  for i := 1 to n do

  begin

    for j := 1 to i do

      write ('*');

    writeln;

  end;

end.

 

11) //Не понял, как заполняется массив? Тут рандом

var

  a : array [1..1000] of integer;

  i, n : integer;

begin

  read (n);

  for i := 1 to n do

    a[i] := trunc (random (1000)) - 500;

  for i := 1 to n do

    if a[i] > 0 then a[i] := a[i] * (-1)

   else if a[i] < 0 then a[i] := sqr (a[i]);

  for i := 1 to n do

    write (a[i], ' ');

end.

 

12)

var

  n, i, count : integer;

begin

  read (n);

  count := 0;

  for i := 1 to n do

    if n mod i = 0 then inc (count);

  writeln (count);

end.

 

  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота