ник3999
30.09.2020 23:15

Напишите программу, которая составит все возможные комбинации из цифр 3.4.5.6. и проверит каждую из этих комбинаций, является ли она точным квадратом

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Liza6789456
11.10.2020 00:03

Объяснение:

var a,b,c,d:integer;

begin

for a:=3 to 6 do

   for b:=3 to 6 do

       for c:=3 to 6 do

           for d:=3 to 6 do  begin

           if (a<>b) and (a<>c) and (a<>d)  and (b<>c) and (b<>d) and (c<>d)  and (frac(sqrt(1000*a+100*b+10*c+d))=0) then

writeln(a,b,c,d);

end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота