trushinaveronic
15.08.2021 20:07

Написать программу по информатике (можно на c++ , можно на паскале или питоне)
даны два числа. определить цифры, входящие в запись как первого, так и второго числа.

входные данные

программа получает на вход два числа. гарантируется, что цифры в числах не повторяются. числа в пределах от 0 до 1.

выходные данные

программа должна вывести цифры, которые имеются в обоих числах, через пробел. цифры выводятся в порядке их нахождения в первом числе! например ,
даны числа : 564 и 8954
нужно вывести : 5 и 4​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ksenia20066kislova
10.10.2020 23:58

var

 x, y, t, c, n, k: integer;

 a: array [1..10] of integer;

begin

 for t := 1 to 10 do

   a[t] := 0;

 read(x, y);

 t := x;

 while (t <> 0) do

 begin

   c += 1;

   t := t div 10;

 end;

 k := 1;

 for t := 1 to c do

   k *= 10;

 while (x <> 0) do

 begin

   n := y;

   t := x div k;

   while (n <> 0) do

   begin

     c := n mod 10;

     n := n div 10;

     if (c = t) and (a[c + 1] = 0) then

     begin

       write(t, ' ');

       a[c + 1] += 1;

       break;

     end;

   end;

   x := x mod k;

   k := k div 10;

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота