dkurmanbek
04.04.2022 10:19

Решить по информатике 8 класс
программу напишу я сам, но вот как решить ее? по заданной дате надо сразу сказать кто победит, тойсть если называть одно и тоже число всегда будет побеждать тотже игрок

играют двое. задаётся какая-то дата 2020 года. каждый игрок на своём ходе называет более позднюю дату, увеличивая на 1 или 2 либо день в месяце, либо месяц, но не то и другое сразу. при этом сочетание дня и месяца должно оставаться датой. игрок, назвавший 31 декабря, проигрывает. оба играют наилучшим образом. исходя из заданной даты вывести, кто выиграет.

входные данные
в первой строке находятся числа, обозначающие день и месяц.

выходные данные
вывести 1, если выигрывает первый (начинающий) игрок, или 2 - в противном случае.

примеры
входные данные
30 12
выходные данные
2

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tiamaressp035gw
30.06.2020 12:59
#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int n,sum=0; 
float y,k=0; 
cin >> n; 
int *mass = new int[n]; 
for (int i = 0;i < n;++i) 
{
cin >> mass[i]; 

for (int i = 0;i < n;++i) 

if (mass[i] >0 )
{
k++;
y=pow(mass[i],2); 
cout<<y;
sum+=mas[i]
}

system("pause"); 
}

2)#include <iostream>
#include <cmath>
using namespace std;

void main() 
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}
0,0(0 оценок)
Ответ:
Alyona2022
26.08.2021 04:00

Вводятся координаты (x;y) точки и радиус круга (r). Определить принадлежит ли данная точка кругу, если его центр находится в начале координат.

Будем считать, что точка принадлежит кругу, если находится внутри его или на его окружности.

Из любой точки координатной плоскости можно провести отрезок к началу координат. Если длина этого отрезка больше радиуса круга, то точка лежит за пределами круга и, следовательно, не принадлежит ему. Если же отрезок, соединяющий точку и начало координат, меньше радиуса круга с центром в начале координат или равен ему, то точка будет принадлежать кругу.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота