Shinesss7
03.06.2020 07:04

Написать программу сортировки массива из семи чисел равных индексу по убыванию, написать трассировку программы . паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
xach5
06.01.2020 14:03

var a: array[0..9] of integer;

i,k,b,c: integer;

begin

for i: =0 to 9 do

begin

a[i]: =random(100);

writeln(i+1,' число: ',a[i]);

end;

for i: =0 to 9 do

begin

for k: =0 to 9 do

begin

if a[i]

begin

b: =a[i];

c: =a[k];

a[i]: =c;

a[k]: =b;

k: =0;

end;

end;

end;

writeln('числа по возрастанию: ');

for i: =0 to 9 do

writeln(i+1,' число: ',a[i]);

begin

end;

end.

тут немного больше чем надо

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота