Настя2017465
22.10.2020 06:30

Написать программу, чтобы она удаляла все нечетные числа в строке

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Тихий23
10.10.2020 23:26

var

 s, p : string;

 i : integer;

begin

 write('строка: ');

 readln(s);

 writeln(s);

 for i := length(s) downto 1 do  

   if s[i] in ['1', '3', '5', '7', '9'] then delete(s, i, 1);

 for i := length(s) downto 1 do

   if s[i] in ['0', '2', '4', '6', '8'] then

   begin

     p := '(' + s[i] + ')';

     delete(s, i, 1);

     insert(p, s, i)

   end;

 writeln(s);

 readln

end.

Объяснение:

0,0(0 оценок)
Ответ:
Smartfone
10.10.2020 23:26

PascalABC.NET

begin

 var s :='26 декабря 2019 года, четверг, 15 час 43 мин, за окном +3.';

 s := s.Remove

     (

     s.MatchValues('\d+')

     .Select(p -> p.ToInteger)

     .Where(p -> p.IsOdd)

     .Select(p -> p.ToString)

     .ToArray

     );

 Println(s) // 26 декабря  года, четверг,  час  мин, за окном +.

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота