serzh1425
19.09.2022 13:41

Написать программу с шаблонов.
построить список из символов вводимого с клавиатуры текста. вывести на экран первые буквы всех слов входного текста.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ketkovalchuk
23.06.2022 00:57

#include <iostream>

using namespace std;

int main()

{

int sum = 0;

int composition = 1;

bool plusSeq = 1;

int n = 0;

cout << "Size array - ";

cin >> n;

int* a = new int[n];

for (int i = 0; i < n; i++)

{

 a[i] = -10 + rand() % 21;

 sum += a[i];

 composition *= a[i];

 cout << a[i] << "  ";

}

 

for (int i = 0; i < n; i++)

{

 if (a[i] < 0)

  a[i] *= a[i];

}

for (int i = 1; i < n; i++)

{

 if (a[i] < a[i - 1])

 {

  plusSeq = 0;

  break;

 }

}

if (plusSeq)

 cout << "\nSum = " << sum;

else

 cout << "\nComposition = " << composition;

delete[]a;

return 0;

}

Объяснение:

0,0(0 оценок)
Ответ:
yulyaahunova1
23.06.2022 00:57

#include <iostream>

using namespace std;

int main()

{

int sum = 0;

int composition = 1;

bool plusSeq = 1;

int n = 0;

cout << "Size array - ";

cin >> n;

int* a = new int[n];

for (int i = 0; i < n; i++)

{

 a[i] = -10 + rand() % 21;

 sum += a[i];

 composition *= a[i];

 cout << a[i] << "  ";

}

 

for (int i = 0; i < n; i++)

{

 if (a[i] < 0)

  a[i] *= a[i];

}

for (int i = 1; i < n; i++)

{

 if (a[i] < a[i - 1])

 {

  plusSeq = 0;

  break;

 }

}

if (plusSeq)

 cout << "\nSum = " << sum;

else

 cout << "\nComposition = " << composition;

delete[]a;

return 0;

}

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота