таллвовоч
21.12.2022 21:53

Напишите программу, которая во введённой символьной строке заменяет все буквы «а» на букву «о»

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kiranovm14
23.06.2022 15:35
Function Square(x1, y1, x2, y2, x3, y3: real): real;
begin 
    Square := abs((x2 - x1) * (y3 - y1) - (x3 - x1) * (y2 - y1)) / 2;
end;

var 
  x1, y1, x2, y2, x3, y3, s1, s2: real;

begin 
  write('Задайте первый треугольник(x1,y1,x2,y2,x3,y3): '); 
  readln(x1, y1, x2, y2, x3, y3); 
  s1 := Square(x1, y1, x2, y2, x3, y3); 
  write('Задайте второй треугольник(x1,y1,x2,y2,x3,y3): '); 
  readln(x1, y1, x2, y2, x3, y3); 
  s2 := Square(x1, y1, x2, y2, x3, y3); 
  if s1 > s2 then writeln('Площадь первого треугольника больше') 
  else if s1 < s2 then writeln('Площадь второго треугольника больше') 
  else writeln('Площади треугольников равны');
end.

p.s. проверять существуют ли такие треугольники не нужно, т.к. они уже заданы и нам нужно определить площадь большего.
0,0(0 оценок)
Ответ:
ekaterina9919
27.05.2023 13:45
1) не ясен вопрос
2) 0 2 6 12 20 30 42 56 72 90
3) 5
4) for i := 1 to 10 do
    begin
        if (a[i] < 0) then
            a[i] := -1
        else a[i] := 1;
        write(a[i], ' ');
    end;

Код полностью

 var
    a: array[1..10] of integer;
    i, k: integer;

begin
    for i := 1 to 10 do
    begin
        a[i] := sqr(i) - i;
        write(a[i], ' ');
    end;
    writeln;
   
    K := 0;
    for i := 1 to 10 do
        if (a[i] > 10) and (a[i] < 70) then
            k := k + 1;
    Write(k);
    writeln;
   
    for i := 1 to 10 do
    begin
        if (a[i] < 0) then
            a[i] := -1
        else a[i] := 1;
        write(a[i], ' ');
    end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота