Апостол16
13.05.2022 07:53

Написать программу которая из слова республика получит блик​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dnabib
20.04.2022 04:11

число — некоторая абстрактная сущность, мера для описания количества.Цифры — знаки, используемые для записи чисел.Цифры бывают разные: самыми распространёнными являются арабские цифры, представляемые знаками от нуля (0) до девяти (9); менее распространены римские цифры, их можно встретить на циферблате часов или в обозначении века (XIX век).Поскольку чисел гораздо больше чем цифр, то для записи числа обычно используется набор (комбинация) цифр. Только для небольшого количества чисел — для самых малых по величине — бывает достаточно одной цифры. Существует много записи чисел с цифр, называемыхсистемой счисления. Величина числа может зависеть от порядка цифр в записи, а может и не зависеть. Это свойство определяется системой счисления и служит основанием для простейшей классификации таких систем, что позволяет все системы счисления разделить на три класса (группы):позиционные;непозиционные;смешанные.

0,0(0 оценок)
Ответ:
тимур623
03.11.2022 07:47

using System;


namespace App {

   internal class Program {

       private static void Main() {

           var a = new[,] {{1, 2, 3}, {1, 2, 3}, {1, 2, 3}};


           for (var j = 0; j <= a.GetUpperBound(1); j++) {

               if (j % 2 == 0)

                   a[0, j] = ColumnSum(j, ref a);

               else

                   a[0, j] = ColumnProduct(j, ref a);

           }


           for (var i = 0; i <= a.GetUpperBound(0); i++) {

               for (var j = 0; j <= a.GetUpperBound(1); j++)

                   Console.Write("{0} ", a[i, j]);

               Console.WriteLine();

           }


           Console.WriteLine();

           Console.ReadLine();

       }


       public static int ColumnSum(int column, ref int[,] a) {

           var sum = 0;

           for (var i = 0; i <= a.GetUpperBound(0); i++) {

               sum += a[i, column];

           }


           return sum;

       }



       public static int ColumnProduct(int column, ref int[,] a) {

           var p = 1;

           for (var i = 0; i <= a.GetUpperBound(0); i++) {

               p *= a[i, column];

           }


           return p;

       }

   }

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота