masky80984Женя
18.01.2021 12:08

Входные данные
программа получает на вход число n 100, являющееся числом строк и столбцов в массиве. далее во входном потоке идет n строк по n чисел, являющихся элементами массива.

выходные данные
программа должна выводить слово yes для симметричного массива и слово no для несимметричного.

примеры
входные данные
3
0 1 2
1 5 3
2 3 4
выходные данные
yes
входные данные
3
0 0 0
0 0 0
1 0 0
выходные данные
no

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Steam1112
20.02.2023 19:11
// PascalABC.NET 3.0, сборка 1088
begin
  var n:=ReadLnString('Введите число: ');
  n:=n.Where(x->x in ['0'..'9']).JoinIntoString('');
  Writeln('Принятое число: ',n);
  var a:=ReadLnChar('Введите искомую цифру: ');
  Writeln('Количество цифр в числе равно ',n.Length);
  if n[1]=n[n.Length] then Writeln('Первая цифра равна последней')
  else Writeln('Первая цифра не равна последней');
  if Pos(a,n)>0 then Writeln('Цифра ',a,' входит в число')
  else Writeln('Цифра ',a,' не входит в число')
end.

Тестовое решение:
Введите число: тут спрятано 456. по частям 764 наше 03число
Принятое число: 45676403
Введите искомую цифру: 0
Количество цифр в числе равно 8
Первая цифра не равна последней
Цифра 0 входит в число

"Школьный вариант"
// PascalABC.NET 3.0, сборка 1088
var
  n:longint;
  i,k:integer;
  sn:string;
  a:char;
begin
  Write('Введите число: '); Readln(n);
  Str(n,sn);
  Write('Введите искомую цифру: '); Readln(a);
  k:=Length(sn);
  Writeln('Количество цифр в числе равно ',k);
  if sn[1]=sn[k] then Writeln('Первая цифра равна последней')
  else Writeln('Первая цифра не равна последней');
  if Pos(a,sn)>0 then Writeln('Цифра ',a,' входит в число')
  else Writeln('Цифра ',a,' не входит в число')
end.

Тестовое решение:
Введите число: 3476573
Введите искомую цифру: 7
Количество цифр в числе равно 7
Первая цифра равна последней
Цифра 7 входит в число
0,0(0 оценок)
Ответ:
koookBook
29.03.2023 08:59
Program day;
var 
a: array[1..30] of integer; 
b, s, i, min: integer;
begin 
min := 999; 
Randomize; 
for i := 1 to 30 do   begin   
a[i] := random(9, -3);   
s := s + a[i];   
Write(a[i]:3); 
end; 
Writeln; 
Writeln('Ниже нуля '); 
for i := 1 to 30 do   begin    if a[i] > 0 then Write(i,'-го ');   
end;   
if a[i] = 0 then b := b + 1; 
Writeln; 
for i := 1 to 30 do    
if a[i] < min then min := a[i];   
Writeln('Самая низкая температура - ', min); 
Writeln('Средняя температура ноября ', s / 30);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота