eX6ToR
29.05.2022 17:36

Составить программу на с++

класс. создать класс куб, свойства класса - ребро куба, методы конструктор по умолчанию и с параметром. метод вывода на экран значение ребра и метод подсчёта поверхности куба. переопределить опрецию разность (куб - число) = куб, объем которого меньше объема исходного на заданное число.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KONERtm
01.02.2023 06:28

ответ:Яка властивість компонентів є основою для малювання? :У середовищі Delphi є широкий спектр стандартних компонентів, які мають найрізноманітніше призначення. Багато з них орієнтовані на ті чи інші графічні задачі. Розглянемо ті компоненти, що призначені для креслення графічних примітивів.

Графічні примітиви це най ші геометричні фігури, такі як окружність, еліпс, прямокутник або квадрат, також закруглений прямокутник або квадрат.

На палітрі компонентів, що містить великий набір об’єктів, які можна додавати на форму проекту, нам потрібно знайти вкладку Additional, вона містить основні графічні компоненти, такі як Image, Shape і Chart. Для графічних примітивів нам підходить компонент TShape. Графічні компоненти дозволяють швидко намалювати зображення, тому що це виконується автоматично по заданим параметрам.

Компонент TShape дозволяє нам виводити най ші геометричні фігури на поверхні форми без застосування методів Canvas. Клас TShape є прямим нащадком класу TGraphControl, тому він поводиться як звичайний компонент управління. Але у нього є неуспадковані властивості: Shape, Pen і Brush.

Share. Ця властивість є основною для креслення примітивів і вона дозволяє визначити тип геометричної фігури, яка вписана в прямокутну область компонента.

Можливі такі її значення:

· stCircle – окружність;

· stEllipse – еліпс;

· stRectangle - прямокутник;

· stRoundRect – прямокутник зі закругленими кутами;

· stSquare – квадрат;

· stRoundSquare – квадрат зі закругленими кутами.

Pen. Ця властивість уявляє собою олівець, що встановлю б малювання границь фігури, тобто колір і вид границь.

Brush. Властивість, що відповідає за пензлик, який визнача б заливання області фігури, тобто колір і вид заповнення об’єкта.

Ці властивості можна змінювати як у процесі дизайну, так и у час виконання програми.

При накресленні фігура займає весь р компонента, який було встановлено на форму. Але якщо задано квадрат або коло, а розміри по горизонталі та вертикалі відрізняються, то фігуру буде накреслено з розміром меншого виміру.

На яікій вкладці знаходиться елемент TShape:Опишите порядок создания массива автофигур типа TShape.

Откройте среду Lazarus, создайте новый проект, в котором будут отображаться в виде линейчатой диаграммы данные из таблицы.

Разработайте интерфейс программы согласно скриншоту.

На форму добавьте компонент Panel как контейнер для компонентов Image и Shape. Разместите на панели компонент Image и 4 компонента Shape (по количеству элементов в массиве). Для создания легенды диаграммы на форму добавим 4 компонента Label.

Объекты TShape принадлежат к типу данных TShape. В разделе описания глобальных переменных опишем следующим образом.

var

Form1: TForm1;

sh: array [1..4] of TShape; // массив типа TShape

implementation

Теперь можно работать с автофигурами, обращаясь к ним, как к элементам массива sh [i]. Аналогично создадим массив типа TLabel для объектов Label.

var

Form1: TForm1;

sh: array [1..4] of TShape; // массив типа TShape

lb: array [1..4] of TLabel; // массив типа TLabel

implementation

Заполнение массивов будет происходить при создании формы.

procedure TForm1.FormCreate (Sender: TObject);

begin

0,0(0 оценок)
Ответ:
Yutik
19.05.2023 02:18
//1)
Type
ty=array[1..25] of integer;

Var
n,i:integer;
ar:ty;

procedure sortbutmeh(var ar:ty;n:integer);
Var
i,j,c:integer;
begin
for i:=1 to n-1 do
for j:=i+1 to n do
if ar[i]<ar[j] then
begin
c:=ar[i];
ar[i]:=ar[j];
ar[j]:=c;
end;
end;

begin
randomize;
readln(n);
writeln('First array:');
for i:=1 to n do
begin
ar[i]:=random(100);
write(ar[i]:4);
end;
sortbutmeh(ar,n);
writeln;
writeln('Array after sortbutmeh()');
for i:=1 to n do
write(ar[i]:4);
end.

//2)
Var
n:integer;

procedure ned(n:integer);
begin
case n of 
1:writeln('Понедельник');
2:writeln('Вторник');
3:writeln('Среда');
4:writeln('Четверг');
5:writeln('Пятница');
6:writeln('Суббота');
7:writeln('Воскресенье');
end;
end;

begin
readln(n);
ned(n);
end.

//3)
Var
s:string;

function lengthbutmeh(s:string):integer;
begin
while pos(' ',s)<>0 do
delete(s,pos(' ',s),1);
lengthbutmeh:=length(s);
end;

begin
readln(s);
writeln(lengthbutmeh(s));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота