alecsYouTube
08.06.2020 02:58

Написать программу на с++

подпрограмма. 3 входных три выходных параметра. выходные через ссылки (три стороны треугольника). три выходных: 1 - периметр 2 - площадь 3. найти наибольшую из 3 сторон

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Саша13398
03.06.2023 19:39

uses crt;
type TRec = Record
FIO: String[20];
TEL: String[7]
end;
var rec: TRec; i:integer;
who:string; flag:boolean;
a: array [1..20] of TRec;

begin
a[1].FIO := 'Иванов Петр';
a[1].TEL := '+374844';
a[2].FIO := 'Крылова Света';
a[2].TEL := '+373129';
a[3].FIO := 'Соловей Иван';
a[3].TEL := '+370929';
//создай дальше до 10 сама
write('Write fio '); readln(who);
for i:=1 to 3 do
begin

if a[i].FIO = who then
begin
writeln('Номер ',who,' = ',a[i].TEL) ;
flag:=true;
end
else
flag:=false;
end;
if flag=false then
writeln('cannot find ',who);
readln;
end.

0,0(0 оценок)
Ответ:
АлиАбдрахманов
03.10.2022 07:55

Я так понимаю, что вы хотели в программе проверить числа на четность/нечетность, но программа по вашему коду этого не сделает.

 

В таком виде должно быть без ошибок, но работает по-прежнему неверно:

 

#include "stdio.h"
//#include "math.h"
#include <iostream>
using namespace std;

int main ( )
{
float *a;
int i,n;
printf("n=");
scanf("%i",&n);
a=(float*)malloc(n*sizeof(float));
for( i=0; i<=n-1;i++ )
{
printf("a[%i]= ",i );
scanf("%i",&a[i]);
}
for (i=0; i<=n-1; i++)
{
if (a[i]<0)
{
printf("oshibka\n");
}
else
{
if (a[i]/2==0)
{
printf("chetnoe \n");
}
else
{
printf("nechetnoe\n");
}
}

}
system("pause");
return 1;
}

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота