1406052005
31.10.2021 12:29

Составьте программу для вычисления выражений < 0a909> =< 0903> +4+l (процессор к580)​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nasta11111112356
10.04.2021 10:54

Задания 4 и 5:

Задание 4:

static void Main(string[] args)

       {

           int N = 10, count, sum = 0;

           int[] mas = new int[N];

           Random rnd = new Random();

           for (int i = 0; i < N; i++)

           {

               mas[i] = rnd.Next(0, 10);

           }

           Console.WriteLine("Массив: ");

           for (int i = 0; i < N; i++)

           {

               Console.Write(String.Format("{0,4}", mas[i]));

           }

           Console.WriteLine();

           Console.WriteLine();

           Console.Write("Введите количество элементов для суммирования (n): ");

           count = Convert.ToInt32(Console.ReadLine());

           if (count > N)

           {

               count = N;

               Console.WriteLine();

               Console.Write("Количество элементов не должно превышать размерность массива.");

           }

           for (int i = 0; i < count; i++)

           {

               sum += mas[i];

           }

           Console.WriteLine();

           Console.Write("Сумма первых " + count + " элементов массива = " + sum);

           Console.ReadKey();

       }

Задание 5:

static void Main(string[] args)

       {

           int N = 10, x, y, sum = 0;

           int[] mas = new int[N];

           Random rnd = new Random();

           for (int i = 0; i < N; i++)

           {

               mas[i] = rnd.Next(0, 10);

           }

           Console.WriteLine("Массив: ");

           for (int i = 0; i < N; i++)

           {

               Console.Write(String.Format("{0,4}", mas[i]));

           }

           Console.WriteLine();

           Console.WriteLine();

           Console.Write("Введите x: ");

           x = Convert.ToInt32(Console.ReadLine());

           Console.Write("Введите y: ");

           y = Convert.ToInt32(Console.ReadLine());

           if (x > N)

           {

               x = N / 2;

           }

           if (y > N)

           {

               y = N;

           }

           if (y < x)

           {

               x = N / 2;

               y = N;

               Console.WriteLine();

               Console.Write("x не должен быть больше y.");

           }

           for (int i = x - 1; i < y; i++)

           {

               sum += mas[i];

           }

           Console.WriteLine();

           Console.Write("Сумма элементов массива, с " + x + " элемента по " + y + " равна " + sum);

           Console.ReadKey();

       }

Объяснение:

Задания 4 и 5 на языке C#.

0,0(0 оценок)
Ответ:
Куколканупка
18.12.2020 14:23

Модели объектов и процессов можно разбить на пять групп: вербальные, математические, кибернетические, табличные, графические.

Под вербальными моделями понимаются описательные модели в цифровом виде, пригодном для обработки на компьютере. В эту группу входят и математические модели, доведенные до стадии алгоритма.

Кибернетические модели — это модели, использующие принцип «чёрного ящика». О внутреннем содержании этого состояния можно судить, подавая сигналы на вход «ящика» и наблюдая его реакцию на выходе из «ящика».

В группу табличных информационных моделей попадают электронные таблицы видов «объект - свойство», «объект - объект» и «двоичная матрица». В каждой строке таблицы «объект - свойство» содержится информация об одном объекте или одном событии. В таблицах «объект - объект» отображаются взаимосвязи между разными объектами. В таблицах «двоичная матрица» отображается качественный характер связи между объектами.

В группе графических информационных моделей выделяют четыре вида моделей: схемы, чертежи, карты, графы. Графы, в свою очередь, разбиты на две категории — иерархические системы и сети.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота