SleepWalker5669
15.04.2023 02:25

1. дан массив а=(2, -9, -3, 1, 4, -3, 6, -7, -4, 9)
а) описать массив в разделе var
b) чему равно значение а[5]=?
c) чему равно значение: а[2] + а[10] * a[5]=?
d) что получится после выполнения фрагмента программы:
for i: =1 to 10 do
if a[i]=6 then write(‘i=’,i);

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
KristinaSagat55555
18.12.2022 19:47
Const
K = 33;
Var
A:array[1..K] of integer;
i,m,n:integer;
Begin
For i:= 1 to K do
    Begin
    A[i]:=random(21)-10;
    Write(A[i],' ');
    End;
WriteLn;
m:=A[1];
n:=0;
For i:= 2 to K do
    if A[i]<m then m:=A[i];
For i:= 1 to K do
    if A[i]=m then n:=n+1;
WriteLn('Количество минимальных элементов: ',n);
Write('Номера минимальных элементов: ');
For i:= 1 to K do
    if A[i]=m then Write(i,' ')
End.

Пример:

5 0 5 -5 -5 -4 -7 -9 9 8 -4 6 -4 -9 2 -5 -9 4 6 -8 -4 -1 1 -8 -8 -3 -4 2 -9 1 5 -4 -2
Количество минимальных элементов: 4
Номера минимальных элементов: 8 14 17 29
0,0(0 оценок)
Ответ:
WhiteRos
03.01.2020 14:29
Задачи, в которых сумма двух чисел в некоторой системе счисления дает цифру ноль в последнем разряде результата, очень просты.
Ноль означает, что получено число, которое в данной системе счисления записывается, как 10 (ноль остается, а единица переносится в следующий разряд). А 10, как известно - это запись основания системы счисления в самой этой системе. Например, 4₁₀+6₁₀ = 10₁₀; 1₂+1₂ = 10₂ = 2₁₀;
5₈+3₈ = 10₈ = 8₁₀; ...
В нашем случае последние цифры слагаемых тоже дают 10.
4(q)+3(q)=10(q). Но мы знаем, что 4+3=7 в привычной нам системе, поэтому q=7

ответ: в семиричной.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота