popovapp26
09.09.2021 04:51

Написать программу по блок-схеме

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
chudmaev2003
16.02.2023 10:33

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

setlocale(LC_ALL,"russian");

int num;

cout << "Введите размер массива: ";

cin >> num;

int a[num];

int sum = 0;

cout << "Вводите элементы массива поочерёдно: " << endl;

for(int i = 0; i<num; i++)

{

cin >> a[i];

if(a[i]%5==0 && a[i]%2==0) // находим в массиве числа, кратные 5 и 2

{

 sum = sum + 1;

}

}

cout << "Чётных чисел, кратных пяти и двум: " << sum << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Ответ:
egorcop
17.05.2021 22:04
Begin
  var a: integer;
  readln(a);
  for i: integer := 1 to abs(a) do
    if (a mod i = 0) then
      writeln('> ', i);
end.

function Simple(a: integer): boolean;
begin
  result := true;
  for i: integer := 2 to (a div 2) do
    if (a mod i = 0) then
     begin
      result := false;
      break;
    end;
end;

begin
  var a: integer;
  readln(a);
  writeln(Simple(a));
end.

var
  a: integer;

begin
  readln(a);
  for i: byte := length(a.ToString()) downto 1 do
    write(a.ToString()[i]);
end.

function Simple(a: integer): boolean;
begin
  result := true;
  for i: integer := 2 to (a div 2) do
    if (a mod i = 0) then
     begin
      result := false;
      break;
    end;
end;

function par(a: integer): string;
begin
  for i: byte := length(a.ToString()) downto 1 do
    result += a.ToString()[i];
end;

  
begin
  var a: integer;
  readln(a);
  for i: integer := 1 to abs(a) do
    if ((a mod i = 0) and (Simple(a)) and (par(a) = inttostr(i))) then
      writeln('> ', i);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота