ISMAL2009
30.01.2022 12:50

Составить программу в pascal abc, к данному условию

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
maksimys
20.02.2023 16:08

1) 2*6^0 + 0*6^1 + 1*6^2 + 5*6^3

2) 3 единицы

3) 24D

4) 6

5) 2 раза

Объяснение:

2) 37_{10} = 100101_{2}

3) Переводим число 589_{10} в 16-ичную систему счисления, для этого делим его на 16 и запоминаем остаток. Затем результат деления также делим на 16 и запоминаем остаток. Повторяем эти действия до тех пор, пока частное не будет равно 0:

589 : 16 = 36, остаток 13

36 : 16 = 2, остаток 4

2 : 16 = 0, остаток 2

Затем записываем остатки от деления в обратном порядке: 2 4 13

Заменяем числа больше 9 на буквы

(10 - A; 11 - B; 12 - C; 13 - D; 14 - E; 15 - F)

Результат: 24D_{16}

4)

234_{x} = 94_{10}\\4 * x^0 + 3 * x^1 + 2 * x^2 = 94\\4 + 3x + 2x^2 = 94\\2x^2 + 3x - 90 = 0\\x = 6

5) Посчитаем от 1 до 10 в  6-ичной системе счисления:

1 2 3 4 5 10 11 12 13 14

0,0(0 оценок)
Ответ:
Nastya3748
24.04.2020 08:01

program z1;

var t: integer;

begin

write('С начала суток секунд t = ');

readln(t);

writeln('Это составляет ',t div 3600,' часов ', t mod 3600 div 60,' минут ',t mod 3600 mod 60,' секунд')

end.

Объяснение:

div - целочисленное деление

mod - остаток от целочисленного деления

1 мин = 60 сек

1 час = 60 мин = 3600 сек

t div 3600 - сколько целых часов

t mod 3600 - сколько секунд осталось не считая целых часов

t mod 3600 div 60 - сколько целых минут

t mod 3600 mod 60 - сколько секунд осталось не считая целых часов и целых минут

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота