NeSaRg00d04092003
12.09.2022 01:48

1) перепишите программу в тетрадь

var
a: array[1..200] of integer;
i,n,p,k: integer;
begin
p: =20;
n: =0;
randomize;
for i: 1 to 200 do
a[i]: =random(100)-50;
for i: =1 to 200 do
write(a[i],' ');
writeln;
for i: =1 to 200 do
if a[i]=p then
begin
writeln('a[',i,']=',a[i]);
n: =n+1;
end;
writeln;
writeln(n);
end.

2) напишите программу в pascalabc.

3) ответьте письменно на вопросы. запишите ответы в тетрадь.
3.1. сколько элементов в массиве?
3.2. какой фрагмент программы отвечает за запись элементов массива в памяти компьютера?
3.3. в каких пределах целых чисел могут находиться элементы массива?
3.4. для чего в операторе вывода напечатано ' '?

4) ответьте письменно на вопросы. записать ответы в тетрадь.
4.1. что программа выводит на экран оператором writeln('a[',i,']=',a[i]); ?
4.2. для чего нужна переменная n?
4.3. какая переменная лишняя?
4.4. что программа выводит на экран оператором writeln(n); ?

5) измените код программы так, чтобы программа находила и считала количество элементов равных 0 среди 300 элементов целочисленного массива, значение которого расположены между -20 и 20. написать программу в pascalabc.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
maximbliznetz2p02byq
10.10.2020 22:18

3.1. 200

3.2. for i:1 to 200 do  a[i]:=random(100)-50;

3.3. - \frac{2^{32} }{2} ... \frac{2^{32} }{2}  (т.к 4 байта)

либо -50 ... 50 (рандом)

3.4. Чтобы значения не "склеивались", т.к было расстояние между элементами

4.1. a[номер элемента] = значение элемента "перенос строки"

4.2. Для подсчета количества элементов равных 20

4.3.  k - она объявлена, но не используется

4.4.  Количество элементов равных 20

5.

var

a:array[1..300] of integer;

i,n,p,k: integer;

begin

p:=0;

n:=0;

randomize;

for i:1 to 300 do

a[i]:=random(40)-20;

for i:=1 to 300 do

write(a[i],' ');

writeln;

for i:=1 to 300 do

if a[i]=p then

begin

writeln('a[',i,']=',a[i]);

n:=n+1;

end;

writeln;

writeln(n);

end.

ꟷꟷꟷꟷꟷꟷ      

Не забывайте сказать " "! и, если ответ удовлетворил, то выберите его как "Лучший"    

Бодрого настроения и добра!        

Успехов в учебе!

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота