Vampir181
29.05.2020 02:25

Delphi. нужно написать программу

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Даниил20061605
03.04.2021 18:34

program z1;

ar x,y:integer;

begin

readln(x);

readln(y);

if (x=0) and (y=0) then write(0)

else

begin

if (x>=0) and (y>=0) then write(1);

if (x<=0) and (y>=0) then write(2);

if (x<=0) and (y<=0) then write(3);    

if (x>=0) and (y<=0) then write(4)

end

end.

Объяснение:

Если точка лежит в начале координат, т.е. х = 0 и у = 0, то выводим 0, иначе выводим какой четверти принадлежит точка, начиная с 1 четверти и по порядку.

Нестрогие условия (>= и <=) и оператор write (нет перехода на новую строку) позволяют выводить два номера четверти, если точка лежит на одной из осей, а расположение условий для четвертей по порядку позволяет соблюсти условие о том, что сначала необходимо выводить меньший номер.

0,0(0 оценок)
Ответ:
cehrjdfyflz1603
08.05.2022 06:34

место науки информатики в традиционно сложившейся системе наук (технических, естественных, гуманитарных и т. д.) В частности, это позволило бы найти место общеобразовательного курса информатики в ряду других учебных предметов.

По определению академика А.П. Ершова информатика - «фундаментальная естественная наука, изучающая процессы передачи и обработки информации». Академик Б.Н. Наумов определял информатику «как естественную науку, изучающую общие свойства информации, процессы, методы и средства ее обработки (сбор, хранение, преобразование, перемещение, выдача)».

Уточним, что такое фундаментальная наука и что такое естественная наука. К фундаментальным принято относить те науки, основные понятия которых носят общенаучный характер, используются во многих других науках и видах деятельности. Нет, например, сомнений в фундаментальности столь разных наук как математика и философия. В этом же ряду и информатика, так как понятия «информация», «процессы обработки информации» несомненно имеют общенаучную значимость.

Естественные науки – физика, химия, биология и другие – имеют дело с объективными сущностями мира, существующими независимо от нашего сознания. Отнесение к ним информатики отражает единство законов обработки информации в системах самой разной природы - искусственных, биологических, общественных.

Однако многие ученые подчеркивают, что информатика имеет характерные черты и других групп наук – техническихигуманитарных (или общественных).

Черты технической науки придают информатике ее аспекты, связанные с созданием и функционированием машинных систем обработки информации. Так, академик А.А. Дородницын определяет состав информатики как «три неразрывно и существенно связанные части: технические, программные и алгоритмические средства».

Первоначальное наименование школьного предмета «Основы информатики и вычислительной техники» в настоящее время изменено на «Информатика» (включающее в себя разделы, связанные с изучением технических, программных и алгоритмических средств). Науке информатике присущи и некоторые черты гуманитарной (общественной) науки, что обусловлено ее вкладом в развитие и совершенствование социальной сферы.

Объяснение:


Определите место информатики в ряду других фундаментальных наук:
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота