hzzzkzn99
02.11.2022 18:43

Написать программу где массив целых чисел из 25 элементов, заполнен случайным образом числами из промежутка 10,40
добавить в программу команды для сортировки массива по убывания
добавить в программу команду замены не четных элементов на 0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ЗЫН
11.11.2022 20:54

1321

Объяснение:

Число 2^900 в двоичном виде - это единица с девятьюстами нулями.

Число 7 - это 2^2+2^1+2^0

2^900-2^0=2^900-1=2^899  (в двоичном виде - это 900 единиц)

2^2+2+1 в двоичном виде выглядит как 110.

Операция 2^899-2^2-2^1 в двоичном виде представляет из себя замену предпоследних, 898-й и 899-й единиц на 0. Число в двоичном виде будет выглядеть как 897 единиц, затем два нуля, затем единица.

Значащих нулей в числе 2^900-7 рано двум.

8^740=(2^3)^740=2^(740*3)=2^2220

Число 2^2220 в двоичном виде - это единица с двумя тысячами двести двадцатью нулями.

2220-900+1=1321  То есть при сложении, число 2^900-7 записывается в числе 2^2220 начиная с 1321-го разряда.

Искомое число 8^740+2^900-7 в двоичном виде будет выглядеть как единица, 1319 нулей, 897 единиц, два нуля и одна единица.

Число значащих нулей в этом числе составит 1319+2=1321.

0,0(0 оценок)
Ответ:
Варежкамяу
14.04.2022 11:00
Uses
  Crt;
var
  i,n:integer;
  a,s:real;
begin
  Writeln('Вычисление среднего арифметического');
  Writeln('последовательности действительных чисел');
  Write('Введите количество чисел последовательности ->');
  Readln(n);
  Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
  s:=0;
  for i:=1 to n do
  begin
    Read(a);
    s:=s+a
  end;
  Writeln('Среднее арифметическое введенной последовательности: ',s/n);
  Write('Для завершения работы программы нажмите Enter');
  Readkey
end.

Тестовое решение:
Вычисление среднего арифметического
последовательности действительных чисел
Введите количество чисел последовательности ->5
Введите последовательность. После ввода каждого числа нажмите Enter
5.4
7.8
3.0
1.5
2.3
Среднее арифметическое введенной последовательности: 4
Для завершения работы программы нажмите Enter

Для версии Pascal.ABC.Net:
var
  i,n:integer;
  a,s:real;
begin
  Writeln('Вычисление среднего арифметического');
  Writeln('последовательности действительных чисел');
  Write('Введите количество чисел последовательности ->');
  Readln(n);
  Writeln('Введите последовательность. После ввода каждого числа нажмите Enter');
  s:=0;
  for i:=1 to n do
  begin
    Read(a);
    s:=s+a
  end;
  Writeln('Среднее арифметическое введенной последовательности: ',s/n)
end.
 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота