stesha24
05.05.2022 19:09

Написать программу, которая определяет сумму выручки киоска мороженого за день.
известно, что ежедневно совершается 50 покупок, стоимость мороженого варьируется от 20 до 200 рублей. продажи случайными числами.
в паскале abc

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mariyam2105
18.05.2023 21:46

program z1;

var n,k:integer;

begin

k:=0;

write ('Введите натуральное число (n>9): ');

readln (n);

write ('Цифры натурального числа ',n);

while n>=10 do

begin

if n mod 10 < n div 10 mod 10 then k:=1;

n:=n div 10

end;

if k=1 then write (' НЕ расположены в порядке возрастания')

else write (' расположены в порядке возрастания')

end.

Объяснение:

Вводим число

Цикл с предусловием (условие число больше или равно 10)

Сравнение последней и предпоследней цифр числа, если последняя меньше, то k присваивается значение 1

n присваивается значение целочисленного деления на 10 (отбрасываем последнюю цифру числа)

Если k = 1, то цифры не расположены в порядке возрастания, иначе расположены

0,0(0 оценок)
Ответ:
JodiRimmet27
19.07.2020 00:50

Для начала как его могут называть:

Электронная почта, эл. почта;

Интернет-почта

имейл, мейл (транскрипция с английского)

е-мейл, емейл, емайл (различные варианты транслитерации).

Электронная почта по составу элементов и принципу работы практически повторяет систему обычной (бумажной) почты, заимствуя как термины (почта, письмо, конверт, вложение, ящик, доставка и другие), так и характерные особенности использования, задержки передачи сообщений, достаточную надёжность и, в то же время, отсутствие гарантии доставки.

Достоинствами электронной почты являются: легко воспринимаемые и запоминаемые человеком адреса вида имя_пользователя@имя_домена (например [email protected]); возможность передачи как текста, так и форматированного, а также произвольных файлов (текстовые документы, медиафайлы, программы, архивы и т. д.[1]); независимость серверов (в общем случае они обращаются друг к другу непосредственно); достаточно высокая надёжность доставки сообщения использования человеком и программами, высокая скорость передачи сообщений.

Недостатки электронной почты: наличие такого явления, как спам (массовые рекламные и вирусные рассылки); возможные задержки доставки сообщения (до нескольких суток); ограничения на размер одного сообщения и на общий размер сообщений в почтовом ящике (персональные для пользователей).

В настоящее время любой начинающий пользователь может завести свой бесплатный электронный почтовый ящик, достаточно зарегистрироваться на одном из интернет-порталов.

Объяснение: (половина взята с вики)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота