yuliyaduda11
25.09.2021 04:03

Дан массив nxn, состоящих из целых чисел с одинаковым количеством строк и столбцов:
a = [
[1, 2, 3],
[5, 77, 4],
[11, -2, 44]
]
1) проверьте, есть ли в соседних с отрицательными числами ячейках числа, которые нацело делятся на абсолютное значение этих отрицательных чисел (например -2 – отрицательное число. есть ли среди соседей числа, которые делятся на 2 – да (4 и 44) – ответ да)
2) выведите массив такого же размера nxn, наполненный boolean переменными. значение true должно быть в тех ячейках, которые соответствуют условию из пункта 1 (соседние с отрицательным и делится на значение отрицательного числа), в остальных - false

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Anuffka
13.01.2020 21:04
//дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от -10 до 20.
 //Составьте программу, которая подсчитывает и выводит среднюю температуру по всем дням, 
//когда были заморозки. Гарантируется, что хотя бы в один день были заморозки

var i,x,y  : shortint;
    s      : real;
    t      : array [1..30] of shortint;
begin
  randomize;
  For i:=1 to 30 do
    begin
     t[i]:=random (31)-10; //заполняем таблицу случайным образом (в диапазоне от -10 до 20)
     writeln (i,'  ',t[i]); //строка не обязательная просто позволяет увидеть заполненный массив  
   end;
 for i:=1 to 30 do
   begin
     if t[i]<0 then
        begin
         x:=x+t[i];
         y:=y+1;
       end;
   end;
   s:=x/y;
   writeln ('Средняя температура по дням, когда были заморозки ',s:0:2);
end.
0,0(0 оценок)
Ответ:
guarginia666
23.06.2020 15:13

Информация в компьютере представляется набором кодов, а кодировка определяет то, как от кодов – неких чисел – перейти к тому, что ими закодировано.

Коля получил сообщение, первый символ которого он расшифровал как к. Согласно кодовой таблице КОИ-8 (в первом вложении), первый байт полученного сообщения был CB (в 16-ричной системе счисления). Петя же кодировал свое сообщение в другой кодировке (вторая таблица), в которой CB соответствует Л.

Аналогично, можно получить, что на самом деле должно было быть в сообщении, например, Р (код F2 в кодировке КОИ-8) соответствует т в кодировке Windows.

В итоге исходная строка, которую передавал Петя, окажется такой: "Любая информация может быть представлена с чисел"


Петя и коля пишут друг другу электронные письма в кодировке кои-8. однажды петя ошибся и отправил пи
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота