Екатерина12311111
27.03.2020 07:27

Язык паскаль.программисту было поручено написать программу нахождения произведения отрицательных элементов одномерного целочисленного
на фото​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Julia13662004
18.11.2022 21:02

const n=20;

var a:array [1..n] of integer;

i,max,maxi,min,mini:integer;

begin

write('Массив: ');

for i:= 1 to n do

begin

a[i]:=random(101)+50;

write (a[i],'  ')

end;

max:=a[1];

maxi:=1;

min:=a[1];

mini:=1;

for i:= 1 to n do

begin

if a[i]>max then

begin

max:=a[i];

maxi:=i

end;

if a[i]<min then

begin

min:=a[i];

mini:=i

end

end;

writeln;

writeln('Максимальный элемент ',max,' и его номер ',maxi);

writeln('Минимальный элемент ',min,' и его номер ',mini)

end.

Или (если max или min элемент будет не один)

const n=20;

var a:array [1..n] of integer;

i,max,min:integer;

begin

write('Массив: ');

for i:= 1 to n do

begin

a[i]:=random(101)+50;

write (a[i],'  ')

end;

max:=a[1];

min:=a[1];

for i:= 1 to n do

begin

if a[i]>max then max:=a[i];

if a[i]<min then min:=a[i]

end;

writeln;

for i:= 1 to n do

begin

if a[i]=max then writeln('Максимальный элемент ',max,' и его номер ',i);

if a[i]=min then writeln('Минимальный элемент ',min,' и его номер ',i)

end

end.

0,0(0 оценок)
Ответ:
SadArina
18.05.2020 08:24
//Dev-C++ 5.11

#include <iostream>
#include <ctime>
#include <stdlib.h>
using namespace std;

void cher(int ar1[],int ar2[],int& ar3, int n);

int main(void)
 {int* ar1,*ar2,*arfin;
 int n,a;
 cin>>n;
 ar1=new int[n];
 ar2=new int[n];
 arfin=new int[n*2];
 cout<<"Random or reading? 1-rand, other-read";
 cin>>a;
 if (a==1)
  {srand(time(NULL));
  for(int i=0;i<n;i++)
   {ar1[i]=rand()%10;
   cout<<ar1[i]<<' ';}
   cout<<"\n";
  for(int i=0;i<n;i++)
   {ar2[i]=rand()%10;
   cout<<ar2[i]<<' ';}
   cout<<"\n";}
 else
 {for(int i=0;i<n;i++)
  cin>>ar1[i];
 for(int i=0;i<n;i++)
  cin>>ar2[i];}
 cher(ar1,ar2,*arfin,n*2);
 for(int i=0;i<n*2;i++)
  cout<<arfin[i]<<' ';
 delete []ar1;
 delete []ar2;
 delete []arfin;
 return 0;}

void cher(int ar1[],int ar2[],int& ar3, int n)
 {int* ar3f=&ar3;
 int i1,i2=0;
 for(int i=0;i<n;i++)
  if(i%2==0)
   {ar3f[i]=ar1[i1];
   i1++;}
  else
   {ar3f[i]=ar2[i2]; i2++;}}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота