ппмв
02.09.2021 09:33

Напишите программу для решения на любом языке

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
koblovalv
06.05.2021 23:02

На Java:

1)

int x = new Scanner(System.in).nextInt(); //Вводим возраст

//7-10 - начальная школа

//11-15 - средняя школа

//16-17 - старшая школа

if (x >= 7 && x <= 10)

System.out.println("Начальная")

else if (x >= 11 && x <= 15)

System.out.println("Средняя")

else if (x == 16 || x == 17)

System.out.println("Старшая")

2)

int x = new Scanner(System.in).nextInt(); //Вводим число

if (x > 0)

System.out.println("1");

else if (x < 0)

System.out.println("-1");

else

System.out.println("0");

3)

int x = new Scanner(System.in).nextInt(); //Вводим оценку

switch(x) {

case 5:

System.out.println("отлично");

break;

case 4:

System.out.println("хорошо");

break;

case 3:

System.out.println("удовлетворительно");

break;

case 2:

System.out.println("неудовлетворительно");

}

Объяснение:

Всё это надо записать под отдельные функции, либо под главную исполняемую, чтобы вызвать глобально:

public static void main(String... arguments) {}

0,0(0 оценок)
Ответ:
максаткайрат
12.07.2020 18:47

1)

#include <iostream>

#include <vector>

using namespace std;

int main(){

   srand(time(NULL));

   int n;

   cin >> n;

   vector<int> a(n);

   for(auto &i : a)

       i = rand() % 1001 - 500;

   pair<int,int> k1,k2;

   k1 = k2 = {-1e9,-1};

   for(int i = 0; i < n; i++){

       if(a[i] > k1.first){

           k2 = k1;

           k1 = {a[i],i+1};

       }

       else if(a[i] > k2.first)

           k2 = {a[i],i+1};

   }

   cout << k1.second << " " << k2.second;

}

2)

#include <iostream>

#include <vector>

using namespace std;

int main(){

   int n;

   cin >> n;

   vector<int> a(n);

   for(auto &i : a)

       cin >> i;

   int cnt = 1, mx = a[0];

   for(int i = 1; i < n; i++){

       if(a[i] == mx)

           cnt++;

       else if(a[i] > mx){

           cnt = 1;

           mx = a[i];

       }

   }

   cout << cnt;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота