fuuuuuuu1
19.01.2020 18:24

Синформатикой
напишите программу или блок схему

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mcanya1
03.08.2022 02:20

1)var

a:array[1..5]of integer;

i,n,s:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 s:=0;

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then s:=s+a[i]

 end;

 writeln('Сумма положительных элементов массива равна ', s)

end.

2)var

a:array[1..10]of integer;

i,n,P:integer;

begin

 writeln('Введите число элементов');

 readln(n);

 writeln('Введите число');

 P:=1;

 for i:=1 to n do begin

   read(a[i]);

   if a[i] mod 6 = 0  

   then P:=P*a[i]

 end;

 writeln('Произведение элементов массива кратных 6 равна ',P)

end.

3)var

a:array[1..5]of integer;

n,i:integer;

begin

 writeln('Введите кол-во элементов');

 readln(n);

 writeln('Введите число');

 for i:=1 to n do begin

   read(a[i]);

   if a[i]>0 then begin

   a[i]:=a[i]*3;

   writeln('Новый элемент равен: ',a[i])

 end;

 if a[i]<=0 then begin

   a[i]:=a[i]+5;

    writeln('Новый элемент равен: ',a[i])

 end;

 end;

end.

Буду рад если отметишь мой ответ как лучший

0,0(0 оценок)
Ответ:
Алёна542133
19.11.2022 04:17
Var a,b:array [1..100,1..100] of real;
    current_row,current_column,rows,columns:integer;

begin
  readln(rows);
  readln(columns);

  for current_row := 1 to rows do begin
    writeln();
    for current_column := 1 to columns do begin
      read(a[current_row,current_column]);
      b[current_row,current_column] :=a [current_row,current_column] / 8;
    end;
  end;

  for current_row := 1 to rows do begin
    writeln();
    for current_column := 1 to columns do
      write(b[current_row,current_column]:4, ' ');
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота