LordКавайность
19.12.2022 04:11

Написать программу на языке паскаль которая вызывает из модуля подпрограмму, которая печатает содержимое непустого текстового файла по рядкам, вставляя в начало рядка слово "рядок" и номер этого рядка(4 позиции). ​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
nadyushasukhan
23.08.2020 11:20

interface

procedure PrintText(fn: string);

implementation  

procedure PrintText(fn: string);

begin

 var i := 1;

 foreach var s in ReadLines(fn) do

 begin

   Writeln(i:4, ' ', s);

   i += 1

 end;

end;

end.

uses nekrasov;   // вызывающая программа (другой файл)

begin

 var fn := ReadlnString('Укажи имя файла:');

 if FileExists(fn) then

   PrintText(fn)

 else

   Println('Файл не найден')

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота