alyagipsy
13.12.2020 17:11

с (си) написать программу, которая во вводимом с клавиатуры тексте выберет слова, количество букв «м» в которых будет максимально, и выведет их на экран.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dianadiadyshyn
06.03.2022 03:18
1. Для цикла For

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  for i := 1 to N do
    p:=p*x;
  writeln(x,' в степени ',n,' равно ',p );
end.

2. Для цикла While
var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  while i<=n do begin
    p:=p*x;
    i:=i+1;
  end;
  writeln(x,' в степени ',n,' равно ',p );
end.

3. Для цикла Repeat

var
  x,n,p:longint;
  i:integer;
begin
  readln (x,n);
  p:=1;
  i:=1;
  repeat
    p:=p*x;
    i:=i+1;
  until i>n;
  writeln(x,' в степени ',n,' равно ',p );
end.
0,0(0 оценок)
Ответ:
aytanpashaeva
14.03.2020 05:18
Флэш-память
Устройства, выполненные на одной микросхеме (кристалле) и не имеющие подвижных частей, основаны на кристаллах электрически перепрограммируемой флэш-памяти. Физический принцип организации ячеек флэш-памяти можно считать одинаковым для всех выпускаемых устройств, как бы они ни назывались. Различаются такие устройства по интерфейсу и применяемому контроллеру, что обусловливает разницу в емкости, скорости передачи данных и энергопотреблении.

Multimedia Card (MMC) и Secure Digital (SD) – сходит со сцены из-за ограниченной емкости (64 Мб и 256 Мб соответственно) и низкой скорости работы.
SmartMedia – основной формат для карт широкого применения (от банковских и проездных в метро до удостоверений личности). Тонкие пластинки весом 2 грамма имеют открыто расположенные контакты, но значительная для таких габаритов емкость (до 128 Мбайт) и скорость передачи данных (до 600 Кбайт/с) обусловили их проникновение в сферу цифровой фотографии и носимых МРЗ-устройств.
Memory Stick – “эксклюзивный” формат фирмы Sony, практически не используется другими компаниями. Максимальная емкость – 256 Мбайт, скорость передачи данных доходит до 410 Кбайт/с, цены сравнительно высокие.
CompactFlash (CF) – самый распространенный, универсальный и перспективный формат. Легко подключается к любому ноутбуку. Основная область применения – цифровая фотография. По емкости (до 3 Гбайт) сегодняшние CF-карты не уступают IBM Microdrive, однако отстают по скорости обмена данными (около 2 Мбайт/с).. USB Flash Drive
USB Flash Drive – последовательный интерфейс USB с пропускной Мбит/с или его современный вариант USB 2.0 с пропускной до 480 Мбит/с. Сам носитель заключен в обтекаемый компактный корпус, напоминающий автомобильный брелок. Основные параметры (емкость и скорость работы) полностью совпадают сCompactFlash, поскольку чипы самой памяти остались прежними. Может служить не только “переносчиком” файлов, но и работать как обычный накопитель – с него можно запускать приложения, воспроизводить музыку и сжатое видео, редактировать и создавать файлы. Низкое среднее время доступа к данным на Flash-диске – менее 2,5 мс. Вероятно, накопители класса USB Flash Drive, особенно с интерфейсом USB 2.0, в перспективе смогут полностью заменить собой обычные дискеты и частично – перезаписываемые компакт-диски, носители Iomega ZIP и им подобные.
PC Card (PCMCIA ATA) – основной тип флэш-памяти для компактных компьютеров. В настоящее время существует четыре формата карточек PC Card: Type I, Type II, Type III иCardBus, различающиеся размерами, разъемами и рабочим напряжением. Для PC Card возможна обратная совместимость по разъемам “сверху вниз”. Емкость PC Card достигает 4 Гб, скорость – 20 Мб/с при обмене данными с жестким диском.
Miniature Card (MC) – карточка флэш-памяти, предназначена в основном для карманных компьютеров, мобильных телефонов и цифровых фотокамер. Стандартная емкость составляет 64 Мбайт и больше.

Устройств хранения очень много, ты определись на какие именно будешь делать свой доклад или реферат
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота