Aegon
08.02.2020 19:23

Составить программу: даны три числа, найти их произведение и сумму. дополнительно: дана длина ребра куба. найти площадь грани, площадь полной поверхности и объем этого куба. паскаль абс 7 класс

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ykim1337
25.08.2020 00:24
#include <iostream>

using namespace std;

int main() {
cout << "Привет, Мир!" << endl;
char t;
t = 't';

do {
cout<<'\n';
int a=0, b=0, c=0;
cout << "ВВедите рост Маши: ";
cin >> a;
cout << "ВВедите рост Наташи: ";
cin >> b;
cout << "ВВедите рост Оли: ";
cin >> c;
int d=0;
if (a < b && a < c) d = 1;
if (b < a && b < c) d = 2;
if (c < b && c < a) d = 3;

if (a == b && a < c) d = 4;
if (a == c && a < b) d = 5;
if (b == c && b < a) d = 6;

if (a == b&&b == c) d = 7;

cout<<'\n';
switch (d) {
case 1:
cout << "Рост Маши самый маленький";
break;
case 2:
cout << "Рост Наташи самый маленький";
break;
case 3:
cout << "Рост Оли самый маленький";
break;
case 4:
cout << "Рост Маши и Наташи одинаковый, а Оля выше";
break;
case 5:
cout << "Рост Маши и Оли одинаковый, а Наташа выше";
break;
case 6:
cout << "Рост Оли и Наташи одинаковый, а Маша выше";
break;
case 7:
cout << "Оля, Маша и Наташа одинакового роста";
break;
}
cout<<'\n';
cout<<'\n';
cout<< "Повтрить? (Введите любой символ или '0' - для выхода )";

cin>>t;
}while (t!='0');
return 0;
}
0,0(0 оценок)
Ответ:
яяя615
27.04.2023 15:34

1.

var a:longint;

begin

  read(A);

  if (a mod 10)=(a div 10) then writeln('цифры одинаковы');

  if (a mod 10)>(a div 10) then writeln('вторая цифра больше');

  if (a div 10)>(a mod 10) then writeln('первая цифра больше');

end.

 

2.

var a,b,c:longint;

begin

  read(A);

  b:=a mod 10;

  c:=a div 10;

  b:=b*b*b;

  c:=c*c*c;

  d:=4*(b+c);

  if sqr(A)=d then writeln('квадрат этого числа равен учетверённой сумме кубов его цифр') else writeln(' квадрат этого числа не равен учетверённой сумме кубов его цифр');

end.


3.

var a,b,c,d:longint;

begin

  read(A);

  b:=a mod 10;

  c:=a div 10;

  d:=c+b;

  if d mod 3=0 then writeln('сумма цифр данного числа кратна 3') else writeln('сумма цифр этого числа не кратна 3');

  if d mod 4=0 then writeln('сумма цифр данного числа кратна 4') else writeln('сумма цифр этого числа не кратна 4');

end.


4.

var a,b,c,d,e:longint;

begin

  read(A);

  b:=a mod 10;

  c:=(a mod 100)  div 10;

  d:=a div 100;

  b:=b*b*b;

  c:=c*c*c;

  d:=d*d*d;

  e:=b+c+d;

  if sqr(A)=e then writeln('квадрат этого числа равен сумме кубов его цифр.') else writeln('квадрат этого числа не равен сумме кубов его цифр.');

end.


5.

var a,b,c,d:longint;

begin

  read(b,a);

  c:=b mod 10;

  d:=b div 10;

  if (c=3)or(d=3) then writeln('в запись этого числа входит цифра 3') else writeln('в запись этого числа не входит цифра 3');

  if (c=a)or(d=a) then writeln('в запись этого числа входит цифра ',a') else writeln('в запись этого числа не входит цифра ',a);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота