salsavip333
27.01.2020 08:00

1. составьте программу, которая выводит на экран последовательность кодов введенной с клавиатуры строки. узнайте, как будет выглядет кодировка вашего имени.

вводные данные: андрей

выходные данные: 192 237 228 240 229 233
2. с клавиатуры вводится строка с грамматическими ошибками. составьте программу, позволяющую проверить правописание. выведите на экран количество допущенных ошибок и исправленную строку.
а) правописание "ча" и "ща"
входные данные:
чащя, пуща,чяшка, чайник, гущя
выходные данные:
количество ошибок = 3
чаща, пуща, чашка, чайник, гуща

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SashaRary
06.02.2023 15:15
Незнаю верно ли я все понял, но как вариант можно сделать так
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <iostream>
#include <string>
#include <sstream>
#include <vector>
#include <iterator>
#include <algorithm>

bool DigitFirst(const std::string& rhs, const std::string& lhs)
{
    if (isdigit(rhs[0]) || isdigit(lhs[0]))
        return rhs < lhs;
}

bool LetterFirst(const std::string& rhs, const std::string& lhs)
{
    if (isalpha(rhs[0]) || isalpha(lhs[0]))
        return rhs < lhs;
}

const std::string TrueSort(std::string str, bool(*comparator)(const std::string&
rhs, const std::string& lhs))
{
    std::stringstream ss(str);
    std::vector<std::string> vstr(std::istream_iterator<std::string>(ss), {});
    std::sort(vstr.begin(), vstr.end(), comparator);
    ss.clear();
    std::copy(vstr.begin(), vstr.end(), std::ostream_iterator<std::string>(ss, " "));
    return ss.str();
}

int main()
{
    std::string first  = "position total 12345 2jz asd512fgh";
    std::string second = "year 10010 2018r r98k hello";
    std::cout << TrueSort(first,  DigitFirst ) << std::endl;
    std::cout << TrueSort(second, LetterFirst);
}
0,0(0 оценок)
Ответ:
SanGrey
07.07.2020 23:31
Тернарный оператор должен возвращать значение (или ссылку на переменную), которое потом можно использовать. Например, если в целочисленной переменной a записано число -3, то используя такой синтаксис:
int absa = a >= 0 ? a : -a;
можно присвоить переменной absa значение |-3| = 3.

Выражения break, continue (и, например, return) управляют выполнением программы, показывая, какую инструкцию выполнять следующей, и не возвращают никакого значения (даже void). Поэтому при попытке использовать такие выражения в качестве аргументов тернарного оператора, ожидающего, что оба аргумента вернут какое-то значение, возникает ошибка компиляции.

Если очень хочется использовать тернарный оператор для выхода из цикла (но зачем?) можно выбрасывать исключение, которое потом обрабатывать, например, так:
try {
    int a = 5;
    while(true) {
        a == 0 ? throw "a equals 0" : (void) 0;
        a--;
    }
} catch (char const* s) {
    if (s != "a equals 0") throw s;
};
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота